BrickPi: Yellow indicator flashes 4 times, no SPI response

brickpi3

#1

Hello, my BrickPi turns on, lights blinking and all. Then the software starts without any issues and I can connect seamlessly over the Ethernet and the noVNC. But then, I encounter some problems. The orange light blinks 4 times a second, but I’ve tried all power options and the issue persists. So I pressed Troubleshoot and this is my log:

. As you see, it says there isn’t a response. I’m using rechargeable batteries, but I’ve tested real ones. Raspberry Pi 3 and Brick Pi 3. Also, when I opened Scratch for Robots, it says “NO ROBOT DETECTED”!
Thank you for any help.
P.S.: I haven’t checked before, but this is after I’ve done a DI software update. Shouldn’t be the problem though.
P.P.S: I checked the 'Advanced Communications, and this is what it shows: .


#2

Dexter_Software_Update_log_2019_01_02__21_09_42.txt (148.7 KB)
log.txt (187 Bytes)
Hello, I just wanted to follow up on my problem. I would appreciate any help as I’m kinda stuck right now. Anyways, here’s an edit: I updated the software and firmware manually and using DI software 2 or 3 times. I’ve read every topic on ‘No SPI response’ but I’ve not been able to fix the problem. I’ve tried changing the batteries to normal ones, still no luck. The yellow LED blinks 4 times a second despite everything I try. Here’s a picture of how I mounted it:

.
Yeah, so I’ve also attached the logs from the software update and troubleshooting. I’ve also tried all the example programs, but the Python IDLE tells me ‘No SPI response’. Please help!
Sorry for being so pushy :grin:


#3

It looks like two separate issues.

Regarding the yellow LED flashing four times per second, it sounds like the BrickPi3 is not getting adequate battery voltage. Unless the batteries are nearly dead, using 8xAA batteries should certainly be sufficient. Are you sure the power switch is in the “ON” position? Also, are you able to power the BrickPi3 and RPi from the batteries (without USB power to the RPi)?

Regarding the lack of BP3 SPI response, check to see if SPI is enabled on the RPi. If you run this command: ls /dev/spidev* you should see this: /dev/spidev0.0 /dev/spidev0.1


#4

Thanks for the reply.
Yeah, so when I try to power up the Raspberry Pi 3 with the BrickPi 3 on top of it, it works. I can turn the BrickPi on with only using the batteries; it turns on when I put the switch to on. It also powers on and I can connect over Ethernet to the BrickPi with my computer when I power with USB, USB + 8xAA, or only 8xAA. Regardless of which power version I use, the yellow/orange indicator blinks 4 times a second. I have tried normal, new batteries or my rechargeable ones; I’m pretty sure they work because they work fine in any other appliances.
Now to the SPI command.


As you can see, this is what happens when I type ls /dev/spidev*. I guess it should show that, as stated above.


#5

Any updates whatsoever?


#6

If the BrickPi3 is being powered with 8xAA batteries, and the power switch is ‘ON’ (powers RPi without needing to provide USB power), the yellow LED should be flashing once per second.

Try running the Read_Info.py Python example program.