Chainable LEDs[SOLVED]

Hi Shoban,

I have ordered a new pi3 and a new GrovePi+ startup kit to make sure that I do not have any hardware issues.
Normally it arrives today. I will then use it with Jessie…

As indicated 1.2.6 is not functioning with chainable leds.
Has the 1.2.6 firmware been tested with the DHT temperature and humidity sensors?
I have 2 sensors, a blue one and a white one (I changed the sensor type in my simple python program to test).
None of them seems to work with the 1.2.6. Is this a known issue?

As this is now going on for a very long time and no solution is provided or even foreseen in the near future i would appreciate your honest answer to the following questions:

  1. Will there be sometime in the future a tested solution for this çhainable led
  2. Would it not be better for Dexter to remove this sensor from the GrovePi+ list?

For the last 2 days I am posting results from what I tried but it seems that nobody is reading my messages or bother to answer them.

I also posted another issue concerning unstable port reading.
Again, we know it is a reproducible problem, so I would like to know if there is a recommended python based workaround or solution for it. I posted in a previous threath how I handled t, but again it is not bullet proof.

Last but not least, I am from a small country Belgium, and it is very difficult to purchase a single GrovePi+ board here (startup kit is no problem). The prices they use are also very high comparing to the US especially your preferred dealer in France is ripping people off.
Have you any idea what the import taxes (in %) in Belgium would be if I purchase directly from Dexte?

Kind regards,


Sorry for taking this long to reply back. I had missed this post.

I just tested the chainable RGB led’s at my end and it seems to work. I think it has been working for some time and we also have a small project that uses it here.

Can you try out the following:

  • First make sure that you are using the latest version of Raspbian for Robots from here
  • Next update the GrovePi firmware from here . First make the script executable

sudo chmod +x

then run it :

sudo ./

  • After this, can you check the firmware version from here and make sure it is 1.2.2. (I still have to test it in 1.2.6 and 1.2.7)

  • Next try out the two examples here other than which is there only for historical purpose.

Can you let us know if it works any better. Also, can you start with 4 Chainable LED’s because that is what we have tested with.

There are a few more pointers that you should be careful about:

  • Make sure that the LED are connected in the right way with the input wire connected to the IN port and the wire going to the next port connected to the OUT port otherwise it might not work properly
  • Make sure that you have a beefy power supply. Each of these LED’s takes ~60mA peak so 10 of these could take ~600mA and the Pi could take 1-1.5 A peak. So if you don;t have a good enough power supply then it could make the whole system unstable. We have seen problems around that too. I would suggest using a 5V 3A power supply if you are using 10 of these LED’s.

Coming to the shipping and import duty, they are directly handled when the package enters your country, and most probably you’ll be charged the import duty depending on the import rules and regulation in Belgium.

Do let us know if this helps.

Hi Karan,

Thanks for your message.
So far I tested the following with my new raspberry 3 and grovepi+ 1.2.7

  • Chainable leds: I used a 4 chain of leds (not 10 yet) and it worked as expected. Congrats, I am a happy person with this esult.

  • Port reading: I did a first test and it was without errors. However the test was very brief but I will do a more deep test in the near fuure.

  • I have to do some more testing with my Pi 2 and the old grove board, but I suspect the GrovePi board to be defective. Meybe that was blocking me already from the beginning. I had problems from the early start and needed to make a lot of workarounds for the port reading problem.

I will keep you informed.

Kind regards,


Hey Freddy,
Glad to hear that the chainable LED’s are working for you. I think with 10 LED’s you have to be careful with the power supply.

Regarding the older GrovePi, technically there should be no difference in how the hardware is arranged. Most of the changes are only aesthetic. Can you try uploading a new firmware to the GrovePi and see if that helps.

Do let us know how it goes for you when you get a chance to test it in depth.

Hi Karan,

I now had time to do some in depth testing.
I use 4 chainable leds and still have some errors.
I have a program in Python that I run for several days.
When the ‘sleep’ time is 0.5 sec, the leds are frozen in a certain status after a while.
When this period is increased, it seems to work better.

Please advice.

I have another question.
Since the barometer BMP180 is discontinued, can I use the BMP280 instead.
Are there changes in the python script required to do so?

Kind regards, (2.2 KB)

Can you run this and tell us which firmware version are you running . When you say they were frozen, what did you have to do to get them working normally.

We have not tested the BMP280 and do not have examples for it yet. However, it looks like there are examples avialable for the sensor here and here. You can give it a shot. You can also try out the high accuracy pressure sensor here, though this one is a little costlier.

Hi Kara,

The firmware version I use is 1.2.7.
When the problem occurs, the only solution is to completely shut down the system, leave it without tension for a while, and restart everything again.

Kind regards,

Hi all

I have a similar problem however I am running 20 chainable RGB LEDs. firmware version 1.2.7. If I run a short script such as the test script multiple times ( like 3 times ) in a row, first the LEDs go crazy then they freeze in place. running anything further does change some of them but not the correct ones and not to the correct value. up until then everything works. To fix this I have to reboot as nothing seems to correct them again.

all the best

Hi Karan,

Is somebody working on a solution for this?
It’s more than one year now and things are not going better.
Maybe it would be a good idea to have some kind of command to re-initialize the Led’s periodically.
I tested the current init command and executed the command every 10 minutes, but than the error is even more frequently.
Getting a bit frustrated from it.
I have no other solution because it is a great way to monitor the status of things.
I now also only change the colour only when there is a change necessary.
Otherwise I do not update the colours.

Kind regards,

Hi somebody…

Any news?
It is definitely still not working.
I am trying with delays and so on but for a strange reason this is also not the solution.


Hi Karan,

Any news?
I did some additional testing.
When the LED chain is connected in the highest digital port (number 7) and all other digital sensors to lower ports, it looks like things are going a bit better.
Does that makes any sense to you.
Please be so kind to at least try to answer this post.
For me it is important to know if I should abandon the chainable LED story or not…



Hi, me again…

I discovered another weird thing…
If an RGB display is connected to the system as well and you issue a led colour change just before a change of colour for the display, the LED’s all go into a random state, whatever LED you changed the colour before…

Just trying to help and indicate the different errors I encounter.

Maybe somebody out there is reading this and maybe it is helping to solve a problem.



I am sorry, I had missed this post . We only have 4 of these LED’s at our end so have been able to test only on them. Are the problems that you encounter dependent on the number of LED’s or has it mostly been random till now.

Would you be comfortable working with C. I have been working on a library in C which is very rudimentary but works and it is directly controlled by the Pi, so might work better.

Hi Karan,

Good to hear from you again.
I also use 4 leds to test.
Errors are random, but the change to a higher digital port makes it more stable.
The problem is that one needs to test it together with other sensors.
I use switches, temp and relais.

vriendelijke groeten,


Hi Karen,

Sorry, I have no C experience…

vriendelijke groeten,


I would like to use this

All the best

I just added a Python library for it too. Here is the link. Can you update the repo and try out the new library and example.

It is very basic right now, so I just want you to try it out and see if it works as you want it too. The first LED should be connected to RPISER port.

Also, adding 20 LED’s on the Pi can make it unstable because each LED can use upto 45mA so 20 LED’s can use upto 900mA. Plus they are being turned on/off pretty frequently so the 5V bus voltage will have some interference too.

You should use an external power supply if you can to power the LED’s. Something like this:

Do let me know if this is any better.

Hi Karen,

How can I upgrade the repo?

vriendelijke groeten,


You should run the DI update and it should fetch the files. However all the files in the folders on Desktop would be overwritten.