Espeak don't say what is expected

Using a RPi 3B+.
I made a fresh Raspbian for Robots installation on a new 16GB SD card.
Installed espeak using your guide.
When testing Hello world, it is silent in my speaker.
When using the first, longer test sentence, it sounds but some words are missing.
So, I tested my own sentence and the first word is always missing!!!

espeak -a110 -ven-us “So, once upon a time there was a ghost” 2>/dev/null

It never say “So,” nor any other word, if the word is alone.

1 Like

@RobertLucian Seems like two folks hitting this now.

(I reported it also: After DI Software Update, espeak issue)

Try this - it sort of worked for me (there is distortion, but it is speaking the whole phrase):

Add the following two lines to your /home/pi/.bashrc


and then cause the file to be rescanned:

cd ~
source .bashrc

and try it again
espeak "hello"

This is how we fixed it:

# fix espeak
# 1. set audio to the audio jack
amixer cset numid=3 1
# 2. set volume to 100%
sudo amixer set PCM -- 100%
# 3. remove current espeak
sudo apt-get remove -y espeak
# 4. reinstall espeak and helpers
sudo apt install -y espeak python3-espeak speech-dispatcher-espeak

Hope it works for you too!


I discovered that espeak has a “new, supported” version called espeak-ng (next gen). It is command line compatible.

sudo apt-get install espeak-ng

espeak-ng "Hello from espeak-ng.  Do you hear any distortion?  Do you hear the word last?"

Perhaps it will work better? Please report back if you give it a try.

(For me, the distortion is gone but it still cuts out early. This is an ALSA issue. )

aplay /usr/share/sounds/alsa/Front_Center.wav

AND if you are in rapid need of a fix with no guarantee that other things may not be broken:

sudo rpi-update a08ece3d48c3c40bf1b501772af9933249c11c5b
sudo reboot

will revert just the kernal back to 4.14.98 - espeak and aplay appear to work just fine.

1 Like