Grove- Temperature and Humidity Sensor - Nan Value

I’ve also the Problem with -1C and -1% from the blue sensor. I tried different D ports for the sensor but I only get -1 -1. Then I updated the firmware. Still -1 -1 value. After a long while (ca. 3h) I got a nan error.
I’m using it with a Jessie on a Raspberry Zero W with a GrovePi+.

Hi @nepomuck.ip,

Can you confirm us you are running the /home/pi/Dexter/GrovePi/Software/Python/ script with the blue Grove DHT Sensor plugged into port D4?

Here’s a list of steps I want you to do:

  1. I want to be sure you have the latest version of the GrovePi installed on your RaspberryPi, so please run the sudo curl -kL | bash command in your terminal.

  2. Next, update the firmware of the GrovePi again.

  3. After you do this, please run the troubleshooter which is found at this path location: /home/pi/Dexter/GrovePi/Troubleshooting/
    After you run it, please share with us the log.txt file that has been saved on the Desktop.

  4. Run again the script and tell us if it worked.

I’m waiting for some input from you to see if that solved your issue. If it didn’t, then we need to dive into this issue a bit more.

Thank you!