GrovePi Firmware Update v1.2.2

Maybe you mean this Raspbian image: ?

I’m donwloading it now and will try it later. It doesn’t even mention the GrovePi+ though.


Sorry, yeah that’s the image. Let us know if it helps.


I guess if I buy now the Grovepi+ will need to update from 1.2.2. to 1.2.3.

but, do I need jumper cables to make the update, because I have no idea how to do it…

Hi annlee,
With the newer GrovePi+ you don;t have to do anything with the jumpers to update the software. It has since moved to a software process where you just run the script to update the process. You can find the documentation here: The lates image also comes with a way to update the firmware from the GUI.


Thanks a lot Karan! I certainly need it upgraded to make work the LED bar, and using the light distro “DietPi”

by the way, hope you can help me later with my big project:

Hi anlee,
Happy to help.

Haven’t tried using DietPi before but it might be interesting. You would have to run a setup script to make the GrovePi+ work on it but no gaurantees for DietPi, but you can always use our image or the stock Raspbian image with the Pi.

Do keep us updated about your project and feel free to ask any questions.


Thanks a lot Karan, the reason for using DietPi is it is optimized for fastest boot since my system is an embedded system which does auto-login and launches a .py program at start-up (no GUI also)

will update soon! :smiley:

#offtopic: btw Karan, please have a look at this I posted hope you guys consider a Grove Hat in future

Hi annlee,
Do let us know how it goes.

Pine64 looks very interesting but no commitments for now. Once it’s launched we’ll see how big the demand and the community is around that and decide if it’s worth making a grove HAT for it too.


I’ve just installed the latest avrdude and it doesn’t seem to recognise the gpio programmer id. Any suggestions?



Is the procedure for upgrading the firmware on a GrovePi the same as on a GrovePi+ board? I have a GrovePi (non-plus) that remains stuck on version 255.255.255. Any attempt to upgrade the firmware gives ‘avrdude’ error messages. All other software on the SD card (Raspbian & Dexter) is the most recent, and can be upgraded through the UI…

Kind regards,

Hi Diederik,
The process to update the firmware on an older GrovePi is a bit different. Can you follow the directions here : and let us know if it works for you.


Thank you very much, Karan!

I can confirm that this procedure successfully brought my older (July 2014) board to version 1.2.2.


I am having similar problems to xamlbrewer. Several of the GrovePi devices don’t work for me so I looked to update/upgrade.

I’m running on a Pi3, my OS details are:

Linux raspberrypi-mtc 4.4.9-v7+ #884 SMP Fri May 6 17:28:59 BST 2016 armv7l GNU/Linux
Linux version 4.4.9-v7+ (dc4@dc4-XPS13-9333) (gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611) ) #884 SMP Fri May 6 17:28:59 BST 2016
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 8.0 (jessie)
Release: 8.0
Codename: jessie

Tried checking my firmware version via the in the Troublshooting directory and it gives me:

GrovePi has firmware version: 255.255.255

I have started a discussion over at Github at and got some help from CleoQc, but to no avail. When I try running the GrovePi firmware update I get:

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

I have attached the troubleshooting log just in case it helps.

Might I have a faulty GrovePi??

Hey mark.caukill,
Can you post a picture of your GrovePi setup.


Thanks for getting back to me so quickly karan. Here are three pictures of my RPi with the GrovePi on it. What specifically are you after?


That’s a much older GrovePi. We have special instructions for updating this firmware.

Thank you John. So I followed karan’s instructions for xamlbrewer (#79976) jumpered the appropriate pins and updated the firmware. Now when I test the firmare (using I have verions 1.2.2 - which is a definite improvement over!! When I ran all_tests script I found that I got a ‘wiringPi Not Found (ERR)’ message. So I installed that from But I’m still getting the:

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

message from the script.

This has now gotten to the limit of what I can do. Can anyone suggest where to go from here? Do Dexter Industries replace faulty GrovePis?

Hey mark,
Looks like you got the firmware working on the GrovePi. Basically avrdude works only when you have jumpered the pins and you only need it for firmware updates. I don’t think the avrdude error is a big problem. Can you try out a couple of sensors with the GrovePi just to make sure that it is working fine.


W00t! You are indeed correct karan! It is working well with a button and an LED. Thank you to all those that helped me sort this out. I really appreciate the community care and attention - it makes learning that much more easier and fulfilling when there are people out there that are prepared to help out us NOOBs.