GrovePi Installation

I’ve been following the instructions from and the script is not running as shown in the instructions and therefore, not detecting my GrovePi. Maybe I’m downloading the wrong because the script I’m running does not have the same language or function. Are there two in the GrovePi/Scripts folder?
This is what I get. sh%204

On those instructions, it says you have to run the following command:

curl -kL | bash

Additionally, you’d also have to update the firmware of the GrovePi, by running this in the project’s directory (/home/pi/Dexter/GrovePi):

cd Firmware

You can find out more by looking at the GrovePi’s documentation:

Thank you!

I ran a test log after updating all firmware and software. The check firmware test does not work. What should I do?

log.txt (6.62 KB)

I think you don’t have the I2C device enabled. You can use raspi-config to enable that:

  1. Run sudo raspi-config.

  2. Go to “Interfacing Options” using the arrow keys.

  3. Select the I2C option and enable it.

  4. Reboot.

And then check if running import grovepi; grovepi.version() works in Python. You can also check if address 0x04 shows up when running i2cdetect -y 1.

Let me know if it works.

Thank you!

I made sure I2C was enabled and the GrovePi still didn’t register. I reinstalled the Raspbian for Robots today, went through all the installing instructions again. At one point last week, I had the LED light blinking, but turned the RPi on the next day and no connection.

Today I was doing more research on my problem and the RST light is constantly on. I went through some trouble shooting for that and nothing will get it to turn off. Here is another log.txt file. For some reason, I’ve never been able to get the firmware version to print. I’m at a loss.
log.txt (6.6 KB)

Out of curiosity, do the software and firmware updates have hard coded path names for /home/pi/Desktop/GrovePi? Because I’m using the GrovePi folder that was included in the RforR found at /home/pi/Dexter/GrovePi.

Hearing you say you see the RST light constantly on is a bit worrying. If you do a power cycle on the GrovePi (unplug it and then plug it again), does the RST LED still stay on? If that’s the case, then it could indicate a hardware malfunction, in which case it might need a replacement.

There’s something I haven’t asked you: can you show me what’s the output of the bash command? The output can tell us if we’re dealing with a bad board or not.

Out of curiosity, do the software and firmware updates have hard coded path names for /home/pi/Desktop/GrovePi? Because I’m using the GrovePi folder that was included in the RforR found at /home/pi/Dexter/GrovePi.

Yes, that’s correct. Due to historic reasons, we didn’t choose to move that to other, “more appropriate” directories and instead, we just decided to have everything in the pi’s home directory.

Let me know what your answer to this is.

Thank you!

Should I have the GrovePi folder on the desktop then for updating?

The RST LED stays on constantly.

I’ve included a screenshot of my results of bash command.

Just kidding. I’m so confused as to whether the GrovePi folder needs to be on the desktop or in the Dexter folder. My screenshot was of trying to update in Desktop/GrovePi. The text attached is from the Dexter/GrovePi folder.
firmware_update.txt (3.8 KB)

That firmware flash seems to have worked. Does it still have the RST LED on? I’m wondering because you have been able to flash the firmware.

And yes, when the GrovePi is detected or any other robot for that matter, a symlink is created at boot time on the Desktop.

As for not finding the script in that directory, do an ls on it and see what files are present. If you want to be even safer (although there’s no need to) about it just head over to ~/Dexter/GrovePi/Firmware instead. If that file still isn’t there, get out of that directory and run install command again - it’s the one I have listed way up in this thread.
I have never seen a missing script in that project.

Thank you!

Yes, red RST still on. Still can’t see a connection when using i2cdetect. And led_blink doesn’t work either.

I’ve asked Seeed for a new one but no one has responded back to me yet.

I’m having the same problem with my GrovePi+, the red reset led is still on and all the commands I have found on the forum won’t seems to do anything.
I reflashed the firmware, no luck.
I relaunch the install, everything seems to be ok.
The avrdude command does nothing.
i2cdetect no more.
I also tried gpio mode 8 out and gpio write 8 1


Hi @Mcaviglia, @cortexlegeni,

By the way, there may still be a think you can do. After you flash the firmware, trigger a reset of the GrovePi this way:

avrdude -c gpio -p m328p

Also, make sure there’s nothing connected to the SPI pins of the Raspberry Pi as that can indeed mess up with the flashing process.

If this fails, then I think both of you ought to get a replacement. If that’s the case, then both of you should ask for a new one from where you bought them.

Thank you!

Why are all these references still hard-coded to the ‘pi’ user? Raised this over a year ago (Installing the GrovePi). But the install scripts are still unusable if you don’t use a standard Raspian noob install.

This is such a shame as it makes installing this hat such an unnecessary P.I.T.A.

Hey @leogaggl sorry for the disapointment here! We are always happy to review any pull requests on improved install scripts!

Thank you very much for trying to help me troubleshoot my problem. I received a new GrovePi and plugged it in, connects fine. So I’m guessing my old one was a hardware issue.

1 Like

I the School I teach on, I now have 3 dead GrovePi and I still can’t figure how it appends. I think about static electricity, but can’t confirm it. Is there any way to make a hard reset of the board.
Or is there any way to have a boot log of the GrovePi ?
I have 3 dead card to test so I can burn some.