NodeJs on BrickPi? (SOLVED)

#1

hi there, i recently (April-2019) purchased a BrickPi Starter Kit and unfortunately i am unable to get the NodeJs stuff to work at all, mainy due to various errors related to the serialport package, version dependencies and apparent compile errors on raspberry.

before wasting more time on trying to solve the issues, i wanted to double check, given the age of the nodeJS package and overall sparse comment frequency on this here and anywhere out there, if anybody has successfully got this to work recently ?

Thanks,
ph.

0 Likes

#2

finally found some hints, resulting in the fact that this package no longer works with BrickPi3, but another one (https://www.npmjs.com/package/brickpi3 / https://github.com/byWulf/brickpi3-nodejs) does. i indeed got it to work.

0 Likes