Raspberry pi / vnc viewer cut and paste with mac not working[SOLVED]

I cannot seem to cut/paste data between pi and mac using vnc viewer.
Do I need to configure something here?

I tried the command c and command v

Hi @chris3,

It looks like you are using RealVNC viewer, if so once you open, click on Properties option of the VNC Viewer and on the Inputs tab, turn on Share clipboard with VNC Server. If you are using the latest version you may not find the Inputs Tab then click the Expert tab and enable Server cut Text and Client Cut Text.
If this doesn’t resolve then use the command line option of vncconfig following the instructions given here.

If you are using a tightVNC viewer follow the posts here.

Please let us know if this helps,

After a bit more investigation, this is what you need to do to get copy/paste to work.

VNC into your Pi and start a terminal
sudo apt-get update sudo apt-get upgrade

Note that if you haven’t done those two steps in a bit, it will be somewhat long to execute. The Raspberry Pi Foundation has a security update that will be installed - a very good thing but somewhat long (in the order of minutes, not hours! It’s not terribly long!)

Once these two steps are done you can install this tool : autocutsel

sudo apt-get install autocutsel

This will be quick.

nano ./vnc/xstartup

autocutsel -fork before the last line

Your file should read like this:

xrdb $HOME/.Xresources
xsetroot -solid grey -cursor_name left_ptr
# x-terminal-emulator -geometry 80x24+10+10 -ls -title “$VNCDESKTOP Desktop” &
# x-window-manager &
# Fix to make GNOME work
autocutsel -fork

Ctrl-X, then Y, then Enter to get out of Nano.
Reboot the Pi.

You should now be able to share the clipboards between the two computers.


thanks !!! this worked.

This topic was automatically closed after 24 hours. New replies are no longer allowed.