Rpi3, grovepi+ and Grove GPS sensor

I now have my GPS on a Pi3, and now I’m getting similar results as you.
This was working yesterday, on the same setup. I haven’t changed anything except the camera. (camera cable died)
I’ll look into it later tonight, right now the dog needs a walk

Sorry about that. The dog was being a pest.
It dawned on me that, yes, I changed something and that is the power! If I run it from a battery that is not fully charged then my Gpgga lines are empty. A good power supply fixed my issue.

What is your power source? I don’t know yet if it’s a coincidence for me or not.

Hi Cleo,

Thanks a lot for your input. My setup is powered from an official Rpi wallwart delivering up to 2Amps. I have tried with Rpi + touchscreen and without touchscreen (precisely thinking that maybe power could be an issue), and nothing I tried could make the sensor work.

Attached to this post is a picture of my setup, there are two sensors in the picture, GPS and IMU, the IMU is not connected during tests.

Today I woke up early and I tried something else. I got an Arduino Nano that I had laying around and tried to connect it directly to the GPS sensors without the Grove shield. This is the wiring I used:


VCC -> 5V
RX -> D2
TX -> D3

And then I tried this code: http://www.seeedstudio.com/wiki/Grove_-_GPS#With_Arduino

Nothing. No output whatsoever. :frowning:

At this point I am about to give up, I’m running out of time and I can’t seem to get it to work. If you have any suggestions I’m all ears.

Hi Zilog, it looks like your GPS and your GrovePi are communicating just fine. You can see the time is even incrementing in this output.

[’$GPGGA’, ‘000217.799’, ‘’, ‘’, ‘’, ‘’, ‘0’, ‘0’, ‘’, ‘’, ‘M’, ‘’, ‘M’, ‘’, ‘*4B\r\n’]
Time : 000217.799
Fix status : 0
Sats in view : 0
Altitude : -1.000000
Lat : -1.000000
Long : -1.000000

[’$GPGGA’, ‘000218.799’, ‘’, ‘’, ‘’, ‘’, ‘0’, ‘0’, ‘’, ‘’, ‘M’, ‘’, ‘M’, ‘’, ‘*44\r\n’]
Time : 000218.799
Fix status : 0
Sats in view : 0
Altitude : -1.000000
Lat : -1.000000
Long : -1.000000

For some reason, your GPS sensor isn’t putting out valid data (obviously you’re not at -1 altitude). So one of two tings could be going on. First, you might need to just get a valid GPS fix. I’m not sure if this sensor puts that out when it doesn’t have a fix.

You may also have a non-working GPS sensor.

You may want to ask Seeed to exchange this sensor with another one, the GrovePi and the software are working fine, this is a problem with the sensor.

In the end I sent the sensor back to the distributor because I wasn’t happy with it. I got another one today and this one works right out of the box.

Thanks a lot for your kind advice everyone! This forum is wonderfully supportive, thanks!

Zilog, so glad to hear you’re on your way!! let us know how it works out!

Hi there,

was anyone able to get the grove gps sensor working with raspberry pi 3 and grovepi+?

thanks in advance.

Yes, it looks like the original author @zilog was able to get it to work by replacing a defective GPS sensor. Are you having trouble as well?

Hi @frozentrace,

Can you tell us what all you have tried and also if you have tried the steps mentioned in this post.
Can you also tell us what image you are using on the Pi.


I’m on a RaspberryPi 3, running the Pixel image which is Debian Jessie. I have a classroom full of students trying to get the GPS sensor working on GrovePi boards. None of them work. I doubt they’re all defective sensors. We are all plugged into the RPISER serial port using the dextergps.py file. Windows are nearby and still no data. What could be the problem?

Hi @jwclark,

In the Debian Jessie image the UART is disabled by default. Can you try our Raspbian for Robots Image, it will be a lot more easier to connect to and use in classrooms, GPS should work with it. You can follow the instructions here to install Raspbian for Robots. Learn more about our image here.


@Shoban I opened a new question on this topic. I already installed that image - no luck. This is the link from your website: https://drive.google.com/file/d/0B0WChwP4CnLBU1hLRjBQZndTYU0/view and it points to a Jessie build. Should I be using a different image?

@jwclark, that’s right. As @Shoban points out, the issue is probably the UART not being enabled. You can run Raspbian for Robots (links above) or you can enable UART by running sudo raspi-config and selecting advanced options, from there enabling UART.

Also, it’s worth noting: windows nearby may not be enough skyline to see GPS satellites. You may need to take the boards either right up against a window or outside to pickup GPS sats.

I am using RPI3 (RASPBIAN STRETCH WITH DESKTOP) and grovepi+ and gps sensor. I am not getting any output.
I tried GrovePi/Software/Python/grove_GPS/grove_gps_hardware_test.py no output at all. Could you please tell where I am going wrong? (I disabled bluetooth thinking that it may be using URAT(serial1))

I am using code from http://wiki.seeed.cc/Grove-GPS/

I got the output. I used ttyS0 instead of AMA0.