[SOLVED] GoPigo won't turn on


I have a brand new GoPiGo and trying to start it up for the first time. Assembly is complete, have connected the batteries (brand new) but I cannot get the robot to turn on.

When I push the power button on the red board, I get a red light on the green board but it goes out when I release the power button. If I hold the button down the red light stays on. The instructions are telling me I should see a flashing LED on the red board come on - I get no lights.

If I plug the USB power in the red light comes on the green board and stays solid.

I have the Dexter USB and micro-SD in place.

Any guidance to help troubleshoot this would be helpful.


Hi @rick.l.barber,

Yes, pressing on GoPiGo3’s button triggers the boot up of the Raspberry Pi and hence, both LEDs (of the Pi and of the GoPiGo3) should either blink or stay solid.

Could you make a video showing us the exact behavior you’re seeing?
This is the first time we’re hearing of this issue.

Thank you!

Thanks @RobertLucian,

I have added a video - hopefully it’s enough. You can see when I push (and hold) the button, I get no LEDs on the GoPiGo3 at all and the red LED comes on on the Raspberry Pi. The light on the Pi goes out when I release the button.

If I plug in the USB power, the LED on the Pi comes on and goes out when the USB is removed.

The SD card and Dexter USB are in the correct position.

I’d appreciate your thoughts - thanks.


Hello @rick.l.barber

I am unable to see the video but from your description of it, it sounds like an SD card problem. At least, you’re describing exactly what I’ve seen mine do when the SD card doesn’t work.

You can rewrite the SD card by following these instructions
Please pick the appropriate version of the software, either DexterOS, Raspbian for Robots, or Cinch.

Please do let us know how it goes.

Thanks @cleoqc - will have a look at that.
I struggled with uploading the video - I did put a link via dropbox which I can access from the “Popular links” above.Links

Hi @rick.l.barber,

That sure doesn’t look like a normal behavior - I looked at the video you posted.
As Cleo said earlier, I suggest you reflash the image on your SD card and then try it again.

If that still doesn’t work, then I think we can conclude that’s a faulty board.
Make sure you check the MD5 hash of the image before burning it.

Thank you!

Hi @RobertLucian, @cleoqc,

Thanks for your suggestions. Re flashing the image on the SD card worked. Robot now works as it should.



Yeah!!! Up and running! I’m sorry the out of the box experience didn’t go smoothly, but thanks for coming back and letting us know all is well now.


This topic was automatically closed after 5 days. New replies are no longer allowed.