Accelerometer Reads only 0s


#1

Hello,
I am using the Grove 3-axis Digital accelerometer I have it connected. When I run the grove_i2c_accelerometer.py script I only get readings of (0,0,0) I ran the all_tests.sh script that I’ve inserted the log here:
test.txt (6.2 KB)

I also get the several errors during the changing permissions section saying Operation not permitted. Later I get tee: log.txt Permission denied. I’ve updated the firmware and it’s seeing everything. I also have multiple accelerometers and I’ve tried every combination of accelerometer and wire possible and they all give the same results.
Any help would be appreciated.
Maeve


#2

Hi @mkwentland,

I did some tests too and what I found is that what you are running is not the script meant for the Grove 3-axis Digital Acceloremeter.
Looking at the logs you’ve provided, you can see address 0x53 showing up and that address is for the ADXL345 accelerometer and not for the one you initially thought.

Here are the scripts you need to use for your sensor:

After running the example.py script that is found in the folder I’ve shared with you, I got the following output:

Thank you!