Added a new Project to my fork - please merge


#1

I’ve created a little more advanced example that works with the GrovePi, Seeed RGB_LCD and the DHT Sensor.

The background colors transition from blue through green and yellow and orange to red based on thresholds set in the application. It allows to temperature to be estimated from across the room without reading the actual values on the display.


#2

We’ll try that another way:


#3

On Github, you need to create a pull request if you would like it reviewed/merged.

I’ve done it for you this time - it now shows up here:


#4

I haven’t worked with this project in a while, but I re-downloaded and installed it in preparation for a seminar presentation and now the sensor readings are way out of whack. I’m still using the white DH22 sensors (type 1) on Port 7 and everything else appears the same. But when I run the code, I’m getting a temperature Fahrenheit of 33.6 and a humidity of 1.9%. The temperature in the room is about 72 Can you test this an determine if there was a change to the library that is causing this. I’d like to be able to do a live demo. Where can I start to troubleshoot this? I’ve tried another sensor and the result is the same.


#5

Hey dankline,
Can you try using the latest version of grovepi.py. The one in your zip looks like an older version and might be causing problems. It would be great if you try out the latest library and let us know how it goes.

-Karan


#6

Hi Koran,

I was able to get the DHT to work correctly by updating the GrovePi.py file. I also updated the RGB_LCD but now every time I try to write to the LCD, I get an IOError 5. I tried running the example from the RGB_LCD library and it has the same error. In an effort to correct the issue, I’ve tried all the following:
1.) Tried a different LCD both were Rev 2
2.) Created a new image and installed GrovePi, configured the I2C which detects correctly
Nothing seems to make a difference. I’m starting to wonder if I have an issue on the I2C ports. Can you try the https://github.com/DexterInd/GrovePi/tree/master/Software/Python/grove_rgb_lcd examples and tell me if they work for you? It may be that some upgrade to the RPi.GPIO has broken the RGB_LCD module.


#7

Hey dankline,
I just tried running both example.py and example2.py on a Dexter Industries image and a Stock Raspbian image and it does work well with both of them. Can you try a fresh SD card to see if that works and can you attach a screenshot of the error that you are getting.

-Karan


#8

Thanks for getting back to me Karan. Last night I liberated another RaspberryPi and starting with NOOBS installed Raspbian and applied all updates. I then cloned the GrovePi repository and ran the Install.sh and Setup.py apps. Even with all these changes, the result was the same. Even when running just the RGB_LCD examples.


#9

Here’s a pic of the hookup.


#10

Hey dankline,
Which port is the RGB LCD connected to? It should be connected to one of the three I2C ports and it doesn’t look like you are connecting it to that. Can you try connecting it to the I2C port and let us know how it goes.

-Karan


#11

Hi Karan,

OK. Now that is embarrassing. I should have known better. I had the device turned around and plugged into A2 rather than IC2-3. Problem solved. Thank you for your understanding patience. I can’t believe how much I looked at the setup and didn’t see that. The good news, is that the project works perfectly.

Thanks again,

Dan


#12

Hey Dlad,
Glad to hear that it worked. If you decide to publish you project, do share a link to it.

-Karan


#13

Hey Dan, glad it’s sorted! Can’t wait to see more about your project!


#14

I’ve updated the libraries in the project and submitted a pull request. Thanks for all your help.


#15

Dankline, just merged with the main. Thank you for the contribution!