Air Quality Sensor[SOLVED]


#1

Hello,
I got a problem with an Air Quality Sensor (Analog), this one : http://wiki.seeed.cc/Grove-Air_Quality_Sensor_v1.3/
Yesterday, it worked perfectly, I could read data from the sensor but it didn’t work anymore.
I just got “Error” like answer.
It was plugged on A0 pin, so I tried to plug on A1 and A2 by updating the code but I still got the same error.

I got another sensor (I2C) which is still working : http://wiki.seeed.cc/Grove-TemptureAndHumidity_Sensor-High-Accuracy_AndMini-v1.0/

I was wondering if it was the library grovepi (import grovepi) which could make bug the program ?


#2

Hi @walkpto,

Can you send us a few pictures of your setup with the sensor and also can you follow this guide, generate a test log and post it along with your reply.

-Shoban


#3

Hello @Shoban,

I watched the video concerning how to generate a test log but I put my own website on dex.local, I don’t how to get back the original configuration.
This is a picture of my setup with the 2 sensors : air_quality and temperature_humidity.


#4

Hi @walkpto,

Thanks for sending us the picture, if you aren’t able to run our troubleshooting script from desktop, can you run this script and post the log that it generates.

This script can be found on the GrovePi folder in the Desktop or you can clone it from our repository. To run this script go to the directory which has this script and run the following command:
sudo bash all_tests.sh

Upon running this script a log will be generated in the Desktop, which you should attach with your reply.

-Shoban


#5

Hello @Shoban,

I found the script and I executed it. I’m sending in attached the log file.
I can’t upload the file because I am a new user. Consequently, I will send screenshots of the log.
I can only send one image by post.


#6

The second picture :


#7

The third one :


#8

The last one :

I connected another I2C sensor, so there are 2 I2C ones.


#9

Hi @walkpto,

Thanks a lot for the images and sorry for the delay. It looks like your firmware needs to be updated. Can you do a firmware update by following the steps 3,4 and 5 of this tutorial. After doing a firmware update , can you run this script and post the screenshot of it. If this works good then try the air quality sensor and feedback your comments.

-Shoban


#10

Hello @Shoban,

Thank you very much for advice. Now, this is working :slight_smile:


#11

Hi @walkpto,

Glad that we were able to help you.

-Shoban


#12

Good evening @Shoban

I can only launch the script in this directory :
cd/home/pi/Desktop/GrovePi/Software/Python
I created a copy of this file (grove_air_quality_sensor.py ) in the directory :
/home/pi
but when I executed it, I got also “error”.
At the beginning, I could launch this script in any directory I remembered. So, how is it possible to fix that please ? :slight_smile: Thanks


#13

Hi @walkpto,

If you run the script setup.py from \home\pi\Desktop\GrovePi\Software\Python\ it will install the GrovePi library globally and then you can run this example from any directory. To run the setup.py script, run the following command:
sudo python setup.py install

Please let us know if this helps,
-Shoban


#14

Hello @Shoban,

Yes, this is working, thank you so much :slight_smile:


#15

This topic was automatically closed after 24 hours. New replies are no longer allowed.