Arduberry and nRF24L01+ SPI pins


#1

I want to attach nRF24L01+ (2.4 GHz transceiver) to ArduBerry. Unfortunately this uses all 4 SPI pins. It appears the only way to use it is to unplug the SPI pins, upload code, then replug the nRF24L01+. This is most inconvenient, especially for debugging/development.

Is there any to set the SPI pins to allow it to remain attached?


#2

Hey,
Can you follow the advice here: http://www.dexterindustries.com/forum/?topic=spi-ethernet-enc28j60-not-quite-working/#post-2551 and let us know if that works for you.

-Karan


#3

Karan, I have already looked at that link, but it was very unclear to me if that would really solved the problem or if it is just a temp fix to toggle between uploading sketches and operation.


#4

Hey,
The problem with SPI is that Raspberry Pi controls it and uses it to burn the code to the ATmega328, so to take control from the RaspberryPi to use the SPI, you have to put the pins in input mode. The settings will revert back to the normal SPI setting the moment you upload the code, but maybe you can use a script which does that. Those settings have worked well for a lot of people and once you are no longer burning the code, you might not have to change the settings anymore.

-Karan