Arduberry Unable to upload blink sketch


#1

I have installed Arduberry on a RPI 2 and Jessie following the instructions. Everything seemed to work correctly.

I tried uploading “blink” following this:

https://www.dexterindustries.com/Arduberry/how-to-program-the-arduberry/loading-example-sketch/

I consistently get problems uploading to board.
avrdude: ser_open(): can’t open device “COM1”: No such file or directoryProblem uploading to board.

Please help


#2

@swhobbs2000, I think you have posted a similar problem here too: Can't find programmer id GPIO. Are you using Raspbian for Robots image from Dexter Industries or something else. Can you send a few screenshots of the Arduino IDE with the Programmer option showing what all is available in it.


#3

Hi Karan,

I attach the errors I receive when trying to compile any program with Arduberry. These errors occur 100 % of any time I try to use control shift U to upload or upload using programmer options. They occur day or night, and there is absolutely no way I can upload any program using Arduberry.

I note I have followed the instructions absolutely and am quite disappointed that Arduberry fails absolutely on a fresh install out of the box. I have tried for over a week now and the only thing I have accomplished is that I know I am unable to upload any Arduino program to Arduberry.

I am using Jessie which is the new standard for Raspberry Pi and the only software I am able to buy.

Regards,

Steve


#4

I’m having this exact same issue. i’m running Raspbian Jessie with Pixel on a Pi Zero. followed all of the instructions on https://www.dexterindustries.com/Arduberry/getting-started/.

everything worked fine up until it was time to open Arduino’s IDE

I have no option at all under Tools>>Programmer. The board that is selected by default is Arduino Uno and the port is /dev/ttyAMA0

don’t know how to do a screen shot (ala SnagIt) on a Pi.

Thanks for any help you can give.


#5

Hi @ruffturn,

Can you tell us if you have cloned the ArduBerry folder to Desktop. If you are unable to see the programmers option, it looks like a improper install. To confirm can you take a picture of what you see if not a screenshot.

-Shoban


#6

Shoban,
I appreciate your quick response. I’m at work right now but I can get that information later.
Thanks,Charlie (ruffturn)


#7

Shoban,
I did not clone it to the desktop but did just now and now I have the Arduberry folder on the desktop. I got to the “sudo ./install.sh” step and had a lot of activity on the display. However, it stopped at the command prompt. The instructions say to press “Enter” when prompted. There was no such prompt. I just noticed that the next line says “The script will download the necessary packages used by the GrovePi.” I did not see anywhere in Amazon where I purchased this that a GrovePi was necessary. Is a GrovePi required to use the ArduBerry?
Thanks,Charlie


#8

Hi @ruffturn,

You don’t have to have GrovePi to use ArduBerry.The packages might have been downloaded from GrovePi which were needed for ArduBerry as well.

Can you post screenshots of what you see. Moreover when you reinstall ArduBerry, you will have to remove the previous files.

Goto the locations where the previous ArduBerry folders are and type sudo rm -r ArduBerry from command line to remove them. Then install the ArduBerry folder, if you aren’t able to take screenshots, send us a picture of what you see.

-Shoban


#9

Shoban,
I can evidently only include one image. I attempted to include several which showed my progress through the installation instructions. Attached is the image that shows I have no option of a programmer in the Arduino IDE.
Let me know if you need anything else.
Thanks,Charlie (Ruffturn)


#10

Hi @ruffturn,

Will get back to you on this shortly, thanks for the picture.

-Shoban


#11

Hi @ruffturn,

I tried it today on a fresh Raspbian Jessie image with pixel and the Arduino IDE shows Programmer options to me. Can you tell us what all you observed on installing the script. Also make sure you dont have any duplicates of the repository and have only one which is on the Desktop.

You can also try using our custom Raspbian for Robots image which has the Arduino preinstalled. You can try installing our image following the instructions given here.

-Shoban


#12

Shoban,
I took several pictures of the screen as it installed but I’m only allowed to send one at a time. I can send several emails consecutively with these images if you would like.
Thanks,Charlie


#13

Here’s another.


#14

And another


#15

@ruffturn:
Thanks a lot for the screenshots. It looks like the script detected Arduino IDE already on the image and did not run the changes required to enable the programmers and other settings. Did you run the install script more than once. Can you think of any other way by which the Arduino IDE was installed in there.

Can you try running these commands on the terminal, and see if they help in solving the issue:

sudo rm /usr/share/arduino/hardware/arduino/avr/programmers.txt

then

sudo cp /home/pi/Desktop/ArduBerry/script/programmers.txt /usr/share/arduino/hardware/arduino/avr/programmers.txt

this assumes that there is the Arduberry folder on the Desktop.

Can you try this and let us know if it helps.


#16

Again, I appreciate your help. I’ve had no luck though; always resulting with the same error message: avrdude: AVR device not respondingavrdude: initialization failed, rc-1 Double check communication and try again, or use -F to overide this check.
I have consistently received this result after: Formatting, downloading, burning & installing the most recent NOOBS Formatting, downloading, burning & installing the most recent jessie Replacing existing programmers.txt with ArduBerry programmers.txt Format & reinstall jessie & found no__difference between the two versions of that file Edited rpi version uncommenting the “gpio.programmer = gpio” line Formatted, downloaded, burnt & installed Dexter robot version.I’ve also tried different rpi boards; a rpi 3B and a PiZero with same results.
I’m only going to ove this one more day. If you can’t come up with a solution, I’m going to give up and pull my DC jack, voltage regulator and capacitors that I installed on the board and pitch this thing. I’ve spent more time than necessary trying to get this to work. I don’t know what the issue is, but with your instructions, I am unable to make this work.
Thanks, Charlie


#17

Hi @ruffturn,

Really sorry for the frustration, as one last try can you install our image following these instructions and post us a screenshot of how the Arduino IDE looks and what you see on uploading the program. If it isn’t working on our image we will get you a replacement for your board.

-Shoban


#18

Shoban,
Again, I very much appreciate your attention to this. I sincerely hope that we’re able to resolve this. I followed the link that you included in your message and downloaded the zip file, extracted it and burnt the image on a 8g card using SDFormatter & Win32Disimager. I inserted the card into the Pi3 with the ArduBerry attached. When I booted, per instruction I expanded the file system then ran sudo apt-get update & sudo apt-get upgrade. I then rebooted and opened Arduino IDE and ensured that the Pi was selected as the programmer. I opened the Blink sketch and uploaded using programmer. The upload failed again with the same message that I sent before. “avrdude: AVR device not responding…” I really did have high hopes also since I noticed that the image was only days old. I’ve attached a picture of the display. Is there a way that I can edit a config file somewhere so we can try the “-F” to override the check that causes the error?
Thanks again, Charlie


#19

Hi @ruffturn,

I am sorry that it isn’t been working for you, it looks like the issue is with the board, we will arrange you a replacement. If you have bought the ArduBerry directly from our website then you can contact us here under “General Questions and Feedback”:. If you haven’t board the from us directly you will have to approach your dealer.

Thanks a lot for testing it out. I’m really sorry for the frustration and we will make it right immediately.
-Shoban


#20

Shoban,
I bought it from Dexter Industries through Amazon. Would I ask for a return through Amazon?
Thanks,Charlie