Audio sensor problems


#1

Hi!

We are now working on Mission 4, and are having a weird problem with the audio sensor. If I start up scratch and use commands to move the robot, it works. If I use commands to report the audio sensor value, it also works. But, after I have read a value from the audio sensor, none of the commands to move the robot do anything anymore. So, for example, the sample programs that move the robot after the audio sensor value is high enough don’t work, because they move the robot after reading the sensor value. Opening a new program doesn’t restore the motion, but quitting Scratch and then restarting it does. Also, we didn’t have this problem with the light sensor from Mission 3. Any ideas about what could be going on or how to fix it?

Thanks!
-Nat


#2

I’m going on a hunch right now. Could you look in the terminal window (the window that you’re not supposed to close, with a black background).
Are there errors in it after you use the sound sensor and the GoPiGo goes unresponsive?


#3

Yes. I’ve attached a sample program and the error it generates.


#4

THanks nat. I can reproduce it. I’m looking into it.

The Version file that is on the Desktop, if you double click it, it will open and show you some text. Can you give me the date in it? (at the end) and does it say Wheezy or Jessie (you’ll have to scroll right to see it). I expect it to say Wheezy. Could you just confirm, please?


#5

Here is what I get:


#6

thanks. Still investigating over here.


#7

I believe I found the issue (definitely not on your side!)
It’s going through a validation process and will be available within 24 hours if all is well.


#8

Same problem here so I look forward to your fix. Chris.


#9

If you do an update now, it’s supposed to work.
Thank you for your patience on this issue!


#10

Updating the Dexter Software resolved the problem for me.


#11

Good news! Thanks for the feedback.

And onward with the mission! Apologies again, for the delay.


#12

I’ve recently started having this problem again, but this time without the error output in the terminal window. I’ve tried ‘Update GoBox’, I even tried burning a new SD card, updating the Dexter software, then ‘Update GoBox’, but none of it solves the issue. Any suggestions for other things to try or check?


#13

Hello Andreas.
Can you describe the problem you’re having? If you are not seeing the error output in the terminal window, then it’s another problem.


#14

We’re having this exact same problem. Updating Dexter Software now and hoping that will fix it.
We had one additional problem. After running our script many times and wondering why it was ignoring the “broadcast FORWARD” command, we had stopped the script and were scratching our heads about what could be wrong. Suddenly, the robot started moving, we picked it up and the wheels continued to move. We couldn’t stop it. We’d click the “Stop GoPiGo” and it would stop for a fraction of a second and start again. We finally had to manually turn off the robot and reboot. Strange.


#15

OK. Software update completed. Rebooted. Script still doesn’t work.

Damn.


#16

Hmm, that sounds frustrating…
Could you elaborate? Which script are you trying to run precisely? Is it one you wrote? If it is, it would be ideal if you could share the code here, so I can take a look at it.
Is your GoPiGo running other scripts properly?

Cleo


#17

I’m at work right now, but when I get home I’ll share the script. It’s one we wrote. But it’s very basic. Everything is working on the GoPiGo with other scripts. The basic problem is this: we can get it to give us the audio sensor value and we can broadcast movement to the GoPiGo, but we can’t get it to do both. Once the audio sensor value has been called the movement broadcasts are ignored.


#18

It does sound like the same problem as before. When you try it out tonight, can you check in the terminal window, the one entitled Scratch Controller - do not close, if you see the word Traceback ? It should be a couple of lines before the bottom of the window, if it’s there. If that’s the case, could you paste those few lines in here? (or take a screenshot, or even a photo with your cell - whatever is easier).

When you did “Software Updated”, can you confirm that you’re talking about DI Update, and not GoBox Update? I just want to be certain there’s no confusion.

We’ll get to the bottom of this.
Cleo


#19

Here’s the code


#20

No ‘Traceback’. Here’s the entirety of the Scratch Terminal Window