AVR Device not responding

#41

Hey Karen,

Thanks for the quick response! I downloaded your image and everything seems to be working great. Thanks for all your help! May I suggest that you guys put in your arduberry start up guide that you recommend using your own OS with the arduberry.

Thanks again for your help and quick response! I will be buying from you guys again.

-Dan

0 Likes

#42

Great. Glad to hear that it worked for you. We’ll update the directions ASAP for the Arduberry.

-Karan

0 Likes

#43

Hey Karan,

I am now getting the same error again. I now get it every time I try to use the Arduino IDE, even when no shield is plugged in. I already tried re flashing the OS image. We even tried replacing the programming chip with a working one from an Arduino we had laying around to no luck.

We get the error on both the Raspberry pi B+ or 2.

We had been running code successfully for two weeks and then during one compile it just stopped. This is pretty upsetting because we have a design day presentation on Friday and now do not have anything working. Any help you could provide would be greatly appreciated.

0 Likes

#44

znigh,
What error message are you getting at this point?
Which image are you using at this point?

0 Likes

#45

I’m in the same boat as these other users using a rpi2.

Fresh install of Raspbian for Robots, fresh update of all DexterInudstries software, rebooted.

Launched arduino IDE, loaded blink - wired up an LED for pin 13 and it worked great. That was the last sketch I could ever send to the Arduino.

Here’s my output of avrdude:

pi@dex ~ $ avrdude -c gpio -p m328p

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude done.  Thank you.
0 Likes

#46

update: I can successfully upload a sketch after disconnecting the circuit used with the Arduberry.

Example: For the blink sketch, I have to remove either the ground or pin 13 and I’ll be able to upload a new sketch. Keeping both of them plugged in will result in “AVR device not responding” error.

It’ll be annoying to physically unplug and re-plug circuitry for every sketch iteration.

0 Likes

#47

The easy workaround to this is to use any other pin than 10-13 for the LED or other things when uploading the sketches.

-Karan

0 Likes

#48

Just wanted to point out that this (http://www.dexterindustries.com/topic/avr-device-not-responding/page/2/#post-3235) is still a problem. Just hooked up my Arduberry to my Raspberry Pi B, and used http://www.dexterindustries.com/Arduberry/example-projects-with-arduberry-and-raspberry-pi/blink/ as the guide.

Step 1 tells you to connect the LED to pin 13, which will prevent Step 3 from working.

Took me forever to find out what the problem was (numerous google searches FINALLY landed me here), and I’m a grown man. I feel bad for any kid who would try to stumble through this.

0 Likes

#49

I am also facing the same issue on my device. It is showing Windows 10 Preparing Automatic Repair Error. Is there any solution to fix it?

0 Likes