Battery issues with USB Wifi - trying Bluetooth


#1

I’ve been having issues batteries and was wondering if anyone has any good solutions. I am currently using a Raspberry Pi B+ and the 8 AA battery back and a USB Wifi. The issue is that if you increase the motor speed too much (the kids in the class I’m teaching love to do this) then I lose power to the Wifi and then can no longer control the GoPiGo (Note that I have the same issue with the BrickPi). I’m looking into switching from Wifi to Bluetooth as I believe that will need less power, however I haven’t been successful in setting up a PAN on the Raspberry Pi which is needed to use ssh.

It seems like I’m using the GoPiGo in a pretty straight forward configuration. Has anyone else seen this issue?
Any good battery solutions or help getting Bluetooth working on the Raspberry Pi?


#2

Hi shari,
We have tested the GoPiGo rigorously and we didn’t find any issue with the power tripping or the connection getting lost.

There are two things that can be the culprit here:

  1. Bad batteries: maybe the batteries have become old and are unable to supply the current, maybe replacing them would help.
  2. The WiFi module using too much power: Can you tell us which module you are using. The Pi trips off the power if too much current is being drawn by a USB device. This should’t be an issue though. You can try overriding this by running the following commands: gpio -g write 38 0 gpio -g mode 38 out gpio -g write 38 1. These setting would be disabled after reboot.

Let us know of this helps.

-Karan


#3

Thanks Karan,
I just tried again with brand new batteries. They each measured at 1.61v and full battery pack measured 12.89v. So I think I have item 1 covered. I also tried with my rechargeable batteries and it measured 1.41v.
I’m using an Edimax Technology EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS). (This is one of the mini ones). It is listed as a verified adapter on http://elinux.org/RPi_USB_Wi-Fi_Adapters, although it does say "The EW-7811Un can be powered directly from the Raspberry Pi if the Raspberry Pi is powered using a well regulated power supply. ". I’ve also tried a Realtek Semiconductor RTL8192Cu 802.11n WLAN Adapter - which looks like it should be fine as well. Is there a Wifi that you have had good luck with?
After all that, I’m not able to reproduce the problems I was having in the classroom. I’ll keep playing around with it and when I get the failure again will give you the details. But, if you do have another recommendation on Wifi Adapters I’d try something new.

Thanks,
Shari


#4

Just to hop in here as well: are you using a B+ or a B? The B+ has much better power management. Curious . . .


#5

It’s a B+


#6

The B+ should be your best bet power-wise. Maybe you have some example code we could look at? We’d like to try to recreate this and see if we can find a solution.


#7

Unfortunately I haven’t found a good way to reproduce the original issue. I’m still having issues with the GoPiGo and power though- current issue is that python is reporting a buffer overflow when I turn on my USB camera (this only happens when I’m using the motors and batteries - doesn’t happen with USB power and motors). I’m going to switch back to the BrickPi for now, as I don’t seem to be having issues with that right now. I’ll let you know if I find something more concrete that you can help with.


#8

Hi, I had similar issues with my B+ randomly dropping the Wifi connection. This only happened if I was using the battery pack. Using the micro USB power connector I had no issues at all. I tried the override commands used by karan (above) and this has eliminated the issue. Just wondering if there is alternative long-term solution?


#9

Hey ludy,
I think what the problem might be is that your Wifi adapter tries to draw too much current at some instances which is where the safety feature on the Raspberry Pi kicks in and it switches off the power for a moment which causes the Wifi connection to get broken.

The model B+ supports higher currents upto 1.2A but it has top be enabled. Do check here for alternative ways to enable the high current mode: http://www.raspberrypi.org/forums/viewtopic.php?f=63&t=82823 .

Thanks,
-Karan