Bloxter Lesson 1 doesn't run GoPiGo 2 Dexter OS 2

dexteros

#1

Hello,

I have a GoPiGo version 2. I just downloaded Dexter OS 2 this weekend and burned a flash card with etcher.

I can connect to the robot and bring up the manual arrow buttons and control the robot.

However, when I go to Bloxter Lesson 1 and create a simple program to run the robot forward for 1 second and click the green Run button nothing happens.

How can I troubleshoot this? I don’t see any error messages. Nothing seems to happen at all.


#2

Hello @randgraham
Which subversion of DexterOS 2 is this happening on? 2.1.2 or some other version?


#3

Hello,

I just checked and I downloaded DexterOS_image_2.2_final.zip

Regards,
Rand


#4

Thank you. This allows me to investigate. I’ll come back with more info.


#5

I burned a new SD card with that image, and booted up a GoPiGo2 and had no issues.
Starting from a freshly booted robot, can you get it to move when in Bloxter? Just a simple forward for 1 second.

If that fails, can you go into Python and run the following code ? (Copy/paste is your friend here). Please report if it gives you an error message or if it worked.
Thank you.

import easygopigo as easy
import time

sensor_readings = None

gpg = easy.EasyGoPiGo()


# start
gpg.forward()
time.sleep(2)
gpg.stop()
gpg.backward()
time.sleep(2)
gpg.stop()

How to run the code:


#6

I will give it a try when I get a chance.


#7

I tried this again. Here is what I noticed.

I have a raspberry pi 3 that runs chromium 56 on raspbian 8. When I click the run button nothing seems to happen.

When I try it from Chrome or Firefox on my computer running Ubuntu 18.04, the green button turns to yellow, the text changes to “working” the program runs and the robot moves.

It seems like this is highly dependent on the client web browser.

Is there a browser that is known to be compatible that runs on Raspbian?


#8

Now that’s interesting… hmmm.
I will try it with Raspbian. I do not see at first glance why it wouldn’t work (obviously it doesn’t but we’re not doing anything fancy on that Run button).

Give me a bit of time to investigate, please.

Cleo


#9

I tried it from my regular Pi, using Chromium 58 and it worked fine. Raspbian 8 is Stretch so you should be able to update your Chromium and be ok.
It is a bit slow to load everything up though.

Cleo


#10

Hi Cleo,

I got this working after upgrading my distribution on my Pi.

This was more difficult than I anticipated. First I had to edit a post install script for the tar utility. I also missed a sources file that had jessie configured instead of stretch.

IIRC, Chromium was upgraded to version 65. The run button worked in my basic test and I can move on with some bloxter lessons.

Not sure what the problem was and I suppose I was running a version of Chromium that was more than a year old.

Thanks for your help with this.


#11

@randgraham,
glad to see your robot is up and running now.
You were working on a Jessie image? That is indeed an old image by now. Stretch has been out for over a year, and has substantial changes in it. And indeed, going from Jessie to Stretch is no walk in the park. Glad you figured it out.

Cleo


#12

This topic was automatically closed after 5 days. New replies are no longer allowed.