Brick Pi No SPI Response

I recently downloaded the new raspbian for robots and tried to run some of the test python programs. I searched through the forums and tried several of the solutions for the issue:

No SPI response

I updated the firmware… I believe
Updated the software OS using the desktop “tool/link”

both unsuccessfully.

Any suggestions?


Perhaps a simple solution to your current issue may be to run:

sudo raspi-config
  - enable SPI
  - enable I2C
sudo reboot

Please forgive me for not understanding what OS you might have downloaded.

A lot has changed that you may not be aware of, and the most recent BrickPi user to post did not leave us with any “this is what worked for me” documentation.

Disclaimer: I do not own a BrickPi, BrickPi+, or BrickPi3 and I do not work for Modular Robotics.

My OS recommendation for BrickPi family of products is:

  1. Install "Legacy Raspberry Pi OS",
    configure networking and everything you need for remote access.

  2. Run the config util: sudo raspi-config
    a) enable SPI
    b) enable I2C

    For BrickPi3, install software:
    curl -kL | bash

    For BrickPi or BrickPi+, install software:
    curl -kL | bash

1 Like

So, maybe the issue is I have a Brickpi 2.6, if I use the legacy pi OS is there another location for installation?

I did verify that both I2C and SPI were enabled.


Sorry, I see the link for brikpi_plus, I’ll give that a go and see if I’m successful. Thanks for the quick replies.



Please, please, please, pretty-please do not use Raspbian Bullseye!

Everybody comes on board with something that isn’t working and it turns out they’re using Bullseye.  Many of the older products - like the Grove or Brick Pi - have not had their libraries updated and won’t work on the latest Raspbian images.

Last I heard, they DO work on the “legacy” (Buster) image.

If you want to try Raspbian for Robots, and you have a Pi-4, you have to use the (so called) “experimental”, (Buster), version which supports the Pi-4.

1 Like

Thanks, fortunately I’m using a Pi 3 so it should simplify things and I’ll steer clear of bullseye. Thanks!!


Thanks! Problem solved. A fresh install of legacy raspberry pi os and running the script for the BrickPi plus took care of it!

1 Like