Camera not working

dexteros
picamera

#1

Hi, we are newbies here, playing with the gopigo and the new camera module we just got. Camera module is connected to the raspberry pi camera port. We are in the Bloxster media section. USB drive is connected (tried different USB ports as well). We setup two commands, create a folder “a”, and take a photo. Run the program, it runs for about 3 seconds, assuming it takes the picture and saves it. But when we click on the Camera icon in the Sensor Control Panel, it opens a new browser tab and says:

Photos
If you’re not seeing any photos, you need to make sure a USB key is inserted in the Raspberry Pi (green board) of your robot.

What could we be doing wrong?

Thanks!
Roman


#2

Hello @roman7927
What is the name of your USB drive? We recently discovered (and fixed but it isn’t available yet) that you cannot have spaces in the name of the drive.

Also, since your folder name is simply a single letter, maybe the folder is there but you didn’t notice it?
other_folders

If the “Other Folders” doesn’t show then DexterOS is not able to read your USB drive for some reason.

Cleo


#3

Oh I’m not even getting that Photo page. It opens another page that Says: “Photos. If you’re not seeing any photos, you need to make sure a USB key is inserted in the Raspberry Pi (green board) of your robot.”

I did’t give any names to USB drive. Where do I go about doing that?

I actually suspect that USB drive isn’t mounted. In Bloxter, when I go to “Open File” to let’s save open a saved program from SD Card, but I can also choose USB drive in that window. When I click it, nothing happens.

Do you know how I can initialize the USB drive and mount it properly? Can I do this from PI’s shell that I have access to?


#4

Hello @roman7927

It does look that the issue is with the USB drive. It will mount automatically if you insert it before starting the robot.
However, it must be a FAT32 drive and not NTFS or any other system. Can you either try with another drive, or reformat that one on your laptop?

Thanks,
Cleo


#5

@cleoqc @roman7927 - I have the same problem. I tried with another drive and after formatting the drive FAT32. The problem still persists. @roman7927 - Was the issue resolved for you? If so, can you post how the issue was resolved?


#6

@cleoqc @roman7927 - Any suggestions / pointers?


#7

Can you tell me what version of DexterOS you are currently running?


#8

V2.2.1+


#9

as seen in the top right hand corner


#10

Hi @tnkumar,

When you plug in the USB key into your Raspberry Pi, does it show up in the jupyter's home directory? You can see that in JupyterLab (Menu > Code > Python) on its sidebar - there has to be a folder called USB-Drive if the USB key got mounted. Place a file in your USB key and then see if it appears in your USB-Drive directory - this way we check if USB-Drive is not just an empty, meaningless directory.

Thank you!


#11

Hi @RobertLucian - Earlier, I was not able to see USB-Drive. On moving my drive to a new USB port, I am able to see the drive and also capture images. Thanks very much for a quick resolution of the issue.