Can Upload to ArduBerry[SOLVED]


#1

I am trying to get my Arduberry working with a Raspberry Pi 2 B+. I’ve installed the Arduberry carefully using the instruction to properly position it on the Model B+ header. I’ve gotten through the steps to close the IDR/Software per the instructions on the Arduberry website and rebooted. I’ve done the steps to link /dev/ttyAMA0 to /dev/ttyS0 and selected the linked serial port in the Ardunio IDE. I’ve also selected the GIPO programmer there. I am trying to compile and load blink.c and I keep getting errors that say “programmer is not responding” when the IDE tries to upload to the Aruberry. I have two new Aruberry boards and they both produce the same error. Can someone please help me to figure out what I am doing wrong?

  • Fred

#2

Sorry I have a Raspberry Pi 2 Model B (no plus)…


#3

OK, a little more progress. When I compile the blink sketch and use upload using programmer I do not get any errors but the program does not appear to run. I have verify on upload on so I am guessing that the program is getting into the Arduberry but it does not execute for some reason?


#4

Hi,
The Arduberry does not have an LED on pin 13 which would blink when you upload the code. Can you use “Upload Using Programmer” option to upload the code and select the programmer as GPIO. Can you try connecting an LED to pin 13 to try out blinky and let us know if that works.

-Karan


#5

Thank you Karen. I figured out the need to use “Upload Using Programmer” and I can see that the Blink sketch is toggling pin 13 as it should. I have another questions concerning reseting the ArduBerry but I will post that to a new thread.

-Fred