Cannot Access via dex.local


#1

Hello,

By default, the avahi-daemon is included in the new Raspbian image. However, when I try to access my pi using dex.local on the 2016.10.14_Dexter_Industries_jessie it will not connect.

Can someone help?

Regards,

Howard


#2

Hello Howard,
can you give us a bit more details:
how are you trying to access your Pi? Via SSH or through the browser. And are you running Windows or Mac? Are you on wifi, or connected via Ethernet?

Cleo


#3

Hi Cleo,

I am trying to ping it from my Windows machine. I can do so just fine with the IP address. I have the Pi connected to the ethernet on my cable access point.

The interesting thing is this. When I try to ping it the cmd line states “Pinging dex.local [198.105.244.228] with 32…”. That doesn’t make sense, because my local 192.x.x.x address should show up there. Check out this post to become even more confused Ping Issue .

PS: I have about three other Pi’s connected to my home network and I use hostname.local to access them just fine, so I know what I am doing and I doubt it is a generic issue with my ISP.

I have noticed others on this forum complaining of this same issue, perhaps this is the root and there is something fishy with the image.

HH


#4

Another update.

So I tried to ping, from another pi on my network, dex.local and it worked just fine with mapping to the correct IP address. So, there must be something wrong with my client machine. Running antivirus and will provide an update when it is done.

HH


#5

Since you’re on a Windows network, have you tried accessing dex/ instead of dex.local/ ?

Btw I had a similar situation myself yesterday, and it fixed itself when I rebooted my Windows laptop. I’m running Windows 10 without Bonjour.
Cleo


#6

This makes no sense… You are right, using “ping dex” works. It does not work and maps to that strange IP when I include the “.local”. This does not work for any of the other Pi’s on my network. That is, leaving the “.local” off does not work. Strange…

HH


#7

One more strange thing. I CAN use dex.local when trying to ping or access via the browser from another Pi or computer on my network.

HH


#8

This is one of the weird things happening with networking and Windows. I’d love to get to the bottom of it eventually. In my case it started happening when I switched to a brand new Windows 10 installation (not one that got upgraded from Windows 8). I do not have Bonjour installed, nor iTunes (which would have installed Bonjour). Is that the case with your computer too, perchance?
Over here, some days I need the .local, some days both will work, and some days I need to leave it off. Windows seems very temperamental.
( I also have many Pis on my network, and this situation can happen with any of them)


#9

Hi Cleo,

Thanks for your attention on this.

My laptop does have iTunes installed. I actually forgot that was the client side dependency for avahi-daemon to work.

I guess I will just have to accept this behavior as is. I wish I just knew why that strange IP is being tried only for this image…

HH


#10

Once you log into your dex Pi, what IP does it show? (ifconfig, or through the GUI)
I’m a bit clueless about that IP. It doesn’t correspond to anything installed on the card, and it’s not a valid website. I’ve never encountered that particular IP address before.

As for me, I’ve taken it philosophically :slight_smile: The up side is that I have less letters to type. #alwaysasilverlining


#11

The IP address shows the 192.x.x.x address that the access point assigned… lol who knows.

HH