Cannot get old brickpi to work

I got an original BrickPi(not BrickPi3) in brand new condition and trying to get it to work. I downloaded the Dexter ISO and set it up on a Raspberry Pi 3. I cloned BrickPi git and can run to make the blue LEDs blink. But it looks like serial does not work. I could not make the sensors or motors work.
Is there a way to download some old Dexter OS image to try?


Have you run raspi-config and turned on those interfaces, particularly SPI, i2c, and serial.

Maybe @cleoqc can suggest something?

1 Like

suggest popping a note to

motors: check battery voltage - must be strongly above 7.5v - eight NiMH gets 9.6v.
serial: complicated but try searching the forum for “BrickPi Serial”?

Since your worked, you are on the correct path.


DexterOS will not work with BrickPi+. It’s only meant for the GoPiGo.

You will need to start from Raspberry Pi OS and manually install BrickPi+ libraries:

curl -kL | bash

Here is what I did again:

Downloaded the latest Raspian OS.
Disable bluetooth in config.txt and its related services.
Enabled I2C and Serial interface in raspi-config.
Use the command “curl -kL | bash” to build the library,
Run in its examples, which does not work. But does work. It means the serial communication between Brickpi and Rpi does not work.
I even flashed the 2.5 firmware to BrickPi, still does not work.

1 Like

I used a 12V external power supply as well as the battery pack, same result.