Cannot Ping GoPiGo[SOLVED]


#1

Hello. We are having trouble pinging our GoPiGo. When I try to ping dex.local I get the following:

C:\Users\Family>ping dex.local

Pinging dex.local [fe80::8884:d08e:eca2:987c%13] with 32 bytes of data:
Reply from fe80::8884:d08e:eca2:987c%13: time=1ms
Reply from fe80::8884:d08e:eca2:987c%13: time<1ms
Reply from fe80::8884:d08e:eca2:987c%13: time<1ms
Reply from fe80::8884:d08e:eca2:987c%13: time<1ms

Ping statistics for fe80::8884:d08e:eca2:987c%13:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

I re-imaged the SD card and tried the static IP address. When I changed the end of the IP address by 1 as in the video and tried to ping it, it says the request timed out. I also cannot access dex.local as it says the page is not available.

Could you please provide some guidance as to what to do next? The ethernet lights are both on, and the pwr light is solid red and the ACT light blinks.

Thanks.


#2

Hi @nicole.battles,

It looks like your GoPiGo is responding to your ping. Since it says 0%loss, it looks like you were able to communicate with the GoPiGo on dex.local. The IP address that you are using is an IPv6 address, so it looks a bit different.
Were you able to open dex.local from your browser and access the Pi using the VNC?
-Shoban


#3

No, we cannot access dex.local from our browser. It says it is not available.


#4

Hi nicole sorry for the slow response, we’ve been discussing this with our team to see if we could think of the problem. Could you possibly send us a screenshot of the ping from the command line (so what you’ve pasted above) and then a screenshot of the browser you’re trying to connect through (including the navigation bar). I’m sorry for the extra work.

One thing we’ve seen folks have trouble with before, is not putting the “http://” into the navigation bar of their browser. If you type “http://dex.local/” or “http://dex.local/:8001” in, do you get a better result?


#5


#6

We still cannot access the website even using the suggestions you mention above. The site times out.


#7

Can you try opening this in any browser other than chrome like IE,Firefox or Edge. Also can you try entering the ipv6 address in the browser directly and see if that opens (like directly entering the whole fe80:…:c%6 )


#8

I cannot open http://dex.local in any other browser. It times out.

When I enter the ipv6 address directly in the browser, it takes me to
Google (or whatever search engine that browser is using) and tries to
search for it.


#9

Hi Nicole, I’m sorry this is dragging out so long. We haven’t seen this specific issue before and we’re running out of tools to try to solve it with. You might try these things:

  1. In Chrome, you might try incognito mode. If you try http://dex.local/ in incognito mode, after you’ve established a succesful connection with a ping, are you able to see anything different or do you get the same connection error?

  2. If you have access to a different computer, you might try it there.

  3. You might try to re-image the card again. There could be an issue with having setup a static IP address that’s preventing the computer from connecting.

  4. You might try out Cinch (directions at the bottom here). This is a slightly different version of our software that allows you to make a direct connection over wifi. There may be something on your wifi network that’s preventing the connection.

Again, I’m really sorry for this. We haven’t seen this specific error with network setup before and it’s really puzzling. Thanks for your patience.


#10

Cinch did the trick! Thanks so much.


#11

@nicole.battles: Great to hear that it’s working for you now.


#12

Excellent! So good to hear this did the trick!

Just for future reference, we switched to the Cinch image:


#13

This topic was automatically closed after 12 hours. New replies are no longer allowed.