Can't calibrate line follower[SOLVED]


#1

After connecting through VNC and clicking “Line Follower Calibration” on the desktop, first I got a terminal window with warning message of <Xlib: extension “RANDR” missing on display “:1.0”>, the application still could run.

Then I click “Set Black Line Values”, instead of displaying values on the bottom of the window, it displays lists of values(-1,-1,-1,-1,-1) on a new terminal window and the application hang.

The system software is 2016.06.15_Dexter_Industries_jessie.rar, I didn’t add any extra software yet.
The GoPiGo and line follower were newly bought.


#2

What port is the Line Follower plugged into? When you plug the line follower in, what are you seeing with the LED’s?


#3

The line follower is connected to left top port which is near the left LED on the GoPiGo main board.
On the line follower, I see the right LED is steady green, the left LED is flashing red.

BTW, the Pi is Raspberry Pi 3.


#4

Now I noticed that I connected to the wrong port, thanks for your help and issue fixed:)


#5

Great, glad we got it solved. The Line follower goes on the I2C port, just in case anyone is having the same issue!