Can't connect GoPiGo


#1

Initially followed all instructions getting wifi set up and all was successful. Status was completed and the IP address was showing. Ping thorough command prompt and terminal both worked. After I disconnected the gopigo from the ethernet cable and restarted it, it times out everytime. I tried to start over but now I cant get it to respond even when plugged directly in to computer with the cable.


#2

dchasin,

A few questions for you:
1). Are you using a Mac or PC as your computer?
2). Can you ping dex.local over the wifi connection?
3). Do you have access to an HDMI monitor?
4). How are you powering the Pi when doing this? Can you use the Pi Power supply to ensure you have a solid power situation before proceeding?

Just a few things to try in the meantime:

  • Cycle the wifi on the PC or Mac.
  • Remove and replace the wifi dongle on the Pi.
  • Reboot the PC or Mac. Reboot the Pi.

#3

Thanks for the response - see below
I have a commercial Sonicwall router at my house, do you think this may cause a problem?

1). Are you using a Mac or PC as your computer? PC
2). Can you ping dex.local over the wifi connection? NO (if you mean unplug it from the wired connection and using command prompt “ping dex.local”)
3). Do you have access to an HDMI monitor? Yes
4). How are you powering the Pi when doing this? Can you use the Pi Power supply to ensure you have a solid power situation before proceeding? Was using the power supply. Also tried on battery only with no luck

Just a few things to try in the meantime:- I tried all of these with no luck


#4

Can you try assigning a static IP to the Pi by following the instructions here for windows: https://www.youtube.com/watch?v=P4yg8RYtTJs .

Do let us know if this helps.

-Karan


#5

I tried to follow the youtube instructions but there is not a Autoconfiguration IPV4 address on the network connection details page.


#6

That’s a little strange,c an you share a screenshot of your “Network Connection Details” configuration?


#7

Here you go.


#8

Ok, it looks like you do have IPV4 configured. I’ve attached a crop of your screenshot to try to show you what I mean.

If we back up then to where we were last succesful: can you try to connect to your Pi over ethernet again, login through the browser using VNC. Can you open the “Wifi Setup” button and show me a screenshot of the window that pops up? Also, with your Pi connected to the wifi network, are you able to ping google.com from the terminal program on your Pi?


#9

Still no luck. I tried following the instructions from the video to set a static IP. I used the IPV4 address that you circled. I attached a screen shot when I tried to ping it after I re-inserted the sd card in the raspberry pi.
Also, I can not get to the VNC through the browser since it doesnt see the raspberry pi. I open firefox and type http://dex.local and I just get redirected.
I tried again to ping it from the command prompt with ping dex.local with and without the ethernet cable plugged in.


#10

dchasin, can you try to boot the Pi with your HDMI monitor plugged in? Does it boot properly? I just want to make double sure the image hasn’t somehow been corrupted.


#11

Unfortunately, I don’t have a lot of free time and am only getting back to your last recommendation now. I was hoping this was going to be a lot smoother than it has been. I am unclear as to what you want me to do. I’ve tried pinging the Pi from my desktop and from my laptop. All I get when I try to ping it is “Ping request can not find host dex.local Please check name and try again”. Is there any kind of direct support - even if there is a fee - i would hate to shelve this entire project.
Thanks


#12

Since it doesn’t seem like you’re doing anything wrong in setting up the network, it may be a deeper issue about your specific network that’s preventing you from connecting.

Since we last touched base we developed a new version of the software on the Pi that directly tethers to your computer over wifi. Since you seem to be having a network issue that’s not letting the Pi and your computer give it a shot, this might be your best bet.

Cinch puts up a wifi network called “dex” that can be connected to directly over wifi, no network setup needed. Simply login from your computer to the wifi SSID, and in your browser connect to “http://10.10.10.10”.

You can download it here: https://sourceforge.net/projects/dexterindustriesraspbianflavor/files/Cinch/

And here are the instructions for installing a new image to your sd card: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/