Can't connect GoPiGo3 to Computer

dexteros

#1

PLEASE HELP!

In my robotics class, almost the entire class is having a hard time connecting our GoPiGo3 robots to our computers in order to access the coding lessons. We get the robots to turn on, unplug the network connection, then we find our robots and click connect, but then it just says “limited access.” We’re using a wifi dongle, and we’ve tried anything, but still every time we type in bloxter.com or mygopigo.com into the search bar to access programming our robots, it reads “no internet connection.”

We feel like we’ve tried everything, but if you have any ideas or have run into similar problems, please respond with suggestions!


#2

Hello @mitzyluv.2513

It’s perfectly normal to get “no internet connection” as the GoPiGo doesn’t give you access to the Internet.

Things to verify:

  1. are you indeed connected to the robot? Your browser should not give you access to anything on the Internet, like Youtube for example. If you can reach such a site, then you’re not connected properly.
  2. If the above says you are indeed connected, does the antenna led on the GoPiGo turn blue (it should have been green before)?
  3. Have you tried connecting to http://10.10.10.10

Thanks for any detail you can provide.
Cleo


#3

Hi Cleo,
So, yes, to your first question. I am connected to the robot and have no internet access, however, the light does not turn blue. The light stays green even though my commuter says I’m connected (despite the fact that it says limited access). And yes, I have tried connecting to http://10.10.10.10 though I’m not sure the purpose of this. The screen just shows no interned connection.


#4

Hi @mitzyluv.2513,

The GoPiGo runs a web server (actually the Raspberry Pi) that can also be accessed at address 10.10.10.10 - it only shows up if you’re connected to it over the WiFi.

It’s okay for you to get the no internet connection message - that’s the desired behavior.

As for the WiFi LED not turning purple (from green), there can be a bunch of factors:

  1. Radio interference causing it to fail to connect. We fixed this problem a couple of months ago, so maybe you could tell us what is the version that you’re running? I wonder if you’re on an older version of DexterOS.

  2. Your laptop/smartphone not playing nice. There are times when the computer just fails connecting to an AP. In this case, I’d try something as simple as restarting the computer and try it again.

  3. Something going bad with DexterOS not allowing it to set up the AP properly. We had issues in the past with the AP and we kind of fixed them all, so I kind of doubt there are any more problems with it. Maybe you can share with us the logs from DexterOS.

Also, can you tell us what Raspberry Pi are you using? And if you are somehow using a WiFi dongle?

Thank you!


#5

So, I’m using the GoPiGo3, and yes I am using a WiFi dongle. I tried restarting the computer a few times and still nothing.
Also, what do you mean by sharing the logs from the DexterOS?


#6

Hi @mitzyluv.2513,

We no longer sell WiFi dongles for the Raspberry Pi, so can you tell us what dongle is that you’re using? If you’re not using the specific dongle that we used to sell (the Dexter Industries RTL8188 WiFi), then connecting to the GoPiGo3 won’t be possible.

Next, do you use a Raspberry Pi 3 or 3 B+? If so, then you don’t need to add a WiFi dongle to it - the built-in one can be used.

And by logs, I mean the logs that get written to a USB key. If you plug in a USB key (formatted with FAT32) prior to starting up the Pi, by the time you shutdown the robot, you’ll have some logs saved onto the key. Important clues can be found in the logs.

Thank you!