Can't connect to Browser Stream


#1

Following these instructions:
http://www.dexterindustries.com/GoPiGo/projects/python-examples-for-the-raspberry-pi/raspberry-pi-browser-streaming-robot/

Can get all the way to the last part but when I type in raspberrypi.local I get a server not found error in my browser.

I get the “Starting web server” prompt and all that so I assume everything is working fine.

Thoughts?


#2

This is a somewhat old write-up of the project. My guess is that with our new Raspbian for Robots, you should enter dex.local, not raspberrypi.local
I haven’t tried it myself, so I’m not 100% it will work.

ETA:
http://dex.local:98 worked for me


#3

I can control the motors on GoPiGo through webbrowser except servo and i don’t get streaming video.
I get this error:

mmal: mmal_component_create_core: could not create component ‘vc.ril.camera’ (1)
Error : Failed to create camera component
Error : uuuuuuuuUnable to create camera component
Stop

and this repeats until I stop connection.


#4

Drakenridder,
are you talking about http://www.dexterindustries.com/GoPiGo/projects/python-examples-for-the-raspberry-pi/raspberry-pi-browser-streaming-robot/
or about another project?

I’m asking because the browser-streaming-robot does not offer control through the browser.


#5

Drakenridder: Also sounds like you might not have the camera installed or the camera module installed. Are you using Raspbian for Robots or another image?


#6

Thanks! I found the problem there was some damage to cable of camera. Once replaced it worked. Not 100% because i can see images and i can move around but can’t manipulate pan/tilt mechanisme of camera because i can’t see the button on web browser. And yes i try to use /raspberry-pi-browser-streaming-robot/ and i also want to add 1 O2 sensor and 1 buzzer! It 's for a school project.


#7

I found the second joystick of robot streamer for controling tilt/pan servo. It was invisible because it was dissabled in index.html. I 'm still missing a piece of code for controlling the pan/tilt servo with this button. Unfortunately i’m not a programmer so I hope someone knows whats missing.


#8

The second joystick is referenced as neckJoystick. Here is the function which reads the values: https://github.com/DexterInd/GoPiGo/blob/master/Software/Python/Examples/Browser_Streaming_Robot/robot_web_server.py#L146-L152 and this is how you make the joystick control other things: https://github.com/DexterInd/GoPiGo/blob/master/Software/Python/Examples/Browser_Streaming_Robot/robot_controller.py#L138-L146. Right now it doesn’t do anything other than print debug statements. You can add more functionality here.

-Karan


#9

Just got time off to work on it again and dex.local:98 works.

Am going to try and get the “joystick” for the servo to work now as well as I can’t see it either.

Thanks for the advice!