Can't find programmer id GPIO


#21

okay fresh install of raspbian and making sure I was on the desktop for the clone and the install worked… You may want to change the guide to reflect making extra sure you are on the desktop before running. Thanks for the help :slight_smile:


#22

I had a similar experience. The instructions don’t direct the installation to be performed from the /pi/Desktop folder.

I worked at this quite a while and was successful in installing onto a 8GB card and was able to upload to the ArduBerry the Blink sketch on that card.

However, I have not been able to duplicate this on a 32GB card. I’ve formatted & reinstalled a fresh current (01/11/17) version of jessie. I found that, even though Arduino IDE was installed, the Arduberry installer did not find it and proceeded to install 1.6.1. The Pi did find the ArduBerry but wouldn’t upload through the programmer with pretty much the same error as the OP.
I tried it again, this time formatting & imaging the recent jessie and running the install without having the Arduino IDE already installed. Now I have two ports to choose from (/dev/ttyAMA0 & /dev/ttyS0) and neither of them work. Still can’t upload using the programmer.

I still have an error consisting of “avrdude: AVR device not responding arvdude initialization failed, rec=-1 Double check connections and try again, or use -F to override this check”

Where can I find this option to use the “-F” override?


#23

Weird I was successful on a 32 gb card today. I just did a fresh noobs download then installed raspbian with pixel. Updated and upgraded made sure I was in desktop cloned and followed the rest of the directions and it worked fine.


#24

@ruffturn @brennonscuderi,
Thanks for trying this out. We’ll update the instructions on the website .

@ruffturn, Can you tell us a little more about this [quote=“ruffturn, post:22, topic:2233”]
even though Arduino IDE was installed
[/quote]

Did the Arduino IDE come installed on the Raspbian Jessie. Can you tell us the date of the Jessie image that you are using.

Also, the Arduberry only works with Upload using the Programmer Option.


#25

Hello Shoban,

I have downloaded the Dexter Raspbian Image onto a 16GB SD card over the weekend and proceeded to run. I now have the programmer option for the Raspberry PI but still have issues trying to get the Arduberry to work. I I ran the blink program using port /dev/tty/S0 and received the following error;

avrdude: stk500_recv (): programmer is not responding

I then tried port /dev/ttyAMAO and received the same error. If I attach the Arduino UNO board to the Pi it offers another port (/dev/ttyACMO) and the blink program works through this (but not if you connect to the GND and pin 13 on the Arduberry.

Any ideas?

Thanks,
Ian


#26

@ianduthie76,
How were you trying to upload to the Arduberry. Did you try the Upload using programmer option on the IDE. Did it work, if not can you post a screenshot of the errors in the Arduino IDE.


#27

Hi Karen,

Thanks for the speedy reply. Yes this works when you upload using the programmer option on the IDE. Thanks!!
Next job is to work on my 10 DOF sensor.


#28

I appreciate your help with this. The Jessie version I’m using is dated January 11, 2017.
Another poster mentioned using NOOBS. Last night I downloaded a fresh NOOBS (version December 26, 2016) and installed it. Because NOOBS takes a while to install, I ran out of time. I’ll try it and the scripts you recommended.
Because ArduBerry looks for and installs the Arduino IDE, I have let ArduBerry install it rather then me install it prior. I’ve been hoping that would help.Thanks,Charlie


#29

Hi @ianduthie76 and @brennonscuderi,

Glad that you have it working. @ruffturn please let us know how it goes, we will be happy to help.

-Shoban