Can't find programmer id GPIO


#1

Hi all, I’m using RPI 2B plus Jessie. Dexter industries install tutorial seemed to work fine.

However when I try to upload program I get "avrdude: Can’t find programmer id :GPIO
I have tried Bare minimum, Analogreadserial programs. I tried rebooting, uploading using control shift U
I have also checked board and programmer are setup as per Dexter instructions.

I tried reboot, and also with an RPI zero. I consistently get this error. There is absolutely no way whatsoever I can upload any program to this board.


Arduberry Unable to upload blink sketch
#2

Hi @swhobbs2000,

Can you tell us if you have cloned the ArduBerry repository to the Desktop, if you haven’t then remove the existing repository by moving to the ArduBerry folder where you have cloned and type the command: sudo rm -r ArduBerry . Then clone a new ArduBerry repository from the Desktop folder following the steps 3, 4 and 5 in the getting started guide here..

The idea here is that ArduBerry has to be in the Desktop folder of jessie image for our GPIO related files to be identified.

After this try uploading the examples with Upload using the programmer option in the file menu.

Please let us know if this helps,
-Shoban


#3

Hi Shoban,

I was very careful to clone the repository to the Desktop and it turned up as a folder on my desktop window. I also tried Upload using Programmer but again no luck.


#4

Hi @swhobbs2000,

Sorry for the frustration, if you had removed the previous repository and cloned a new one and if it hasn’t worked for you still, then can you share with us a screenshot of the error that you are getting so that we can try out our end. Also can you tell us which image you are using on your Pi.

Thanks for your patience,
-Shoban


#5

This is the error I’m getting:

Checking …
Avrdude: OK
Arduino IDE: OK
Fetching files:
boards.txt
programmers.txt
avrsetup
Replacing/updating files:
inittab: cp: cannot stat ‘inittab’: No such file or directory
/home/pi/Desktop/Arduberry/script/install_jessie.sh: line 182 inittab: no such file or directory
mv: cannot stat ‘/tmp/inittab.1904’: No such file or directory
OK
cmdline.txt: Backup exists: not overwriting
All Done.
Check and reboot now to apply changes

The ‘Backup exists’ is probably because I ran the ./install.sh script twice :slight_smile:
Running Jessie 8/Pixel O/S downloaded from RaspberryPi.org today.


#6

Hi team,

these are the errors I get. I am running Jessie which has had an apt_update run on it.

Steve


#7

Hi Shoban,

I am having trouble getting a screenshot but I am still not able to get the GPIO working

I am using Jessie on a Raspberry Pi 2b and also tried a zero.

Steve


#8

Screen captures.


#9

Attempted to record the terminal session. Not sure if it helps or not.install_log.txt (25.6 KB)


#10

Hi @rpehlm and @swhobbs2000 ,

It looks like there is an issue and we are working to get it right. In the mean time you can you use our image where Arduberry works good. Our image is a custom Raspbian image and it has Arduino preloaded in it. You can download our image from here and follow this tutorial to install it.

Sorry for the frustration,
-Shoban


#11

Good to know there is an issue and it’s being worked on.
Will try the custom Raspbian solution and see what happens.


#12

Hi Shoban,

I have tried Arduberry again with your image.

I was able to successfully download, install and run your image and upload programs to Arduberry.

Unfortunately the blink sketch mentioned in your getting started failed to blink the led in the seven times I tried.

Then I tried Analog in out serial as an example program. This program failed to produce any meaningful output in Serial monitor. I tried AMA0 and /dev/ttyS0. In fact the program hangs 100% of each and every time I have tried it. I have tried rebooting the Pi and get the same result over and over again.

So now after all this work I am still unable to produce any meaningful output from Arduberry.

It seems that Arduberry was not meant to work with the RPi?

Regards,

Steve


#13

Hi @swhobbs2000,

I am really sorry to hear it isn’t working for you. We have sorted this issue and it should work now. Can you please post a picture of your setup. Also can you post the code that you are using and tell us if you are able to upload the program successfully using the “Upload using programmer” option.

Can you also double check if you are using the latest image “2017.01.22_Dexter_Industries_jessie.rar (1.3 GB)

We will help you the best to have it working for you,
-Shoban


#14

I too am having problems with the ArduBerry programmer giving me no options to select. I am not even sure that I managed to delete the initial file correctly before re-loading in desktop. Any help would be appreciated. I am very new to this and I’ve spent all afternoon working on it with no result.
Thank you


#15

I also can’t select anything in tools programmer. I followed the guide here https://www.dexterindustries.com/Arduberry/getting-started/


#16

Hi @ianduthie76 and @brennonscuderi,

I just tried it today on a fresh Raspbian Jessie image and the Arduino IDE shows Programmer options to me. Can you tell us which image you are using what you observed on installing the script. Also did you clone the Arduberry repository to the Desktop.

You can also try using our custom Raspbian for Robots image which has the Arduino preinstalled. You can try installing our image following the instructions given here.

-Shoban


#17

Hi Shoban,

I think that I have cloned the Arduberry repository to the correct location?
pi@raspberrypi:~/Desktop/ArduBerry

When I installed the script it did not follow all of the steps, for instance, it did not prompt me if I wanted to continue just went straight to re-boot. Here is a copy of some of the program ID from the script page;

pi@raspberrypi:~/Desktop/ArduBerry/script ls 80-arduberry.rules archive install.sh programmers.txt README.md pi@raspberrypi:~/Desktop/ArduBerry/script uname -a
Linux raspberrypi 4.4.34-v7+ #930 SMP Wed Nov 23 15:20:41 GMT 2016 armv7l GNU/Linux
pi@raspberrypi:~/Desktop/ArduBerry/script cat /etc/os-release PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)" NAME="Raspbian GNU/Linux" VERSION_ID="8" VERSION="8 (jessie)" ID=raspbian ID_LIKE=debian HOME_URL="http://www.raspbian.org/" SUPPORT_URL="http://www.raspbian.org/RaspbianForums" BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs" pi@raspberrypi:~/Desktop/ArduBerry/script

I live in the UK. Is it possible to buy your Raspbian for Robots Image SD Card from here?
Thanks


#18

Hi @ianduthie76,

I would encourage you to try once more by removing the existing repository an try to clone once again. Also run the following commands sudo apt-get update and sudo apt-get upgrade and then run the install script. This might help if your image misses any dependencies.

You can download our image for free from here or also buy our SD card with our image from here.

-Shoban


#19

Hi Shoban,

I have removed the Arduberry repository from Desktop and cloned again but the result is the same. I shall try to download onto an SD card.

Thank you for your help.

Ian


#20

I didnt clone to the desktop but i guess the default downloads cause I just followed the directions verbatum… However, I tried cloning to the desktop and running and the install script finished super fast like it didnt do near as much as before and still wasnt working…I tried the sd card download and that works fine, however, it would be nice to get it working with my current sd card cause I have the pi doing other things… Ill try a fresh raspian jessie with pixel and see if i clone to desktop then install fresh if anything changes. Unless you have other ideas.