Cant get dex.local to work and stuff


#1

So i can’t get dex.local to work in the initial test with the terminal in the instructions when getting the grove pi to work. Also, I have noobs installed on my micro sd card already, do I have to reinstall a different version to get it compatible with the grove pi? If anyone is willing to go through the set up with me one on one, that would be great.


#2

dex.local will only work if you’re using the Dexter Industries version of Raspbian, known as Raspbian for Robots. I tried it initially but found it not to be as fully featured as Raspbian on NOOBS. For example, I couldn’t watch YouTube videos in the browser. So, I then installed the NOOBS image and followed the instructions below and the GrovePi works perfectly.

You’ll have to follow the NOOBS related setup on the Dexter website. Please see the followin link:

http://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/setting-software/

Initially, I suggest connecting your Pi to a TV/monitor via an HDMI cable and a USB keyboard, do the above set up and set up WiFi. What I then did was install TightVNC and SSH on my PC (and my Chromebook) and now I can remotely access the Pi. You’ll need to find the IP address of your Pi first and that can be done by going into your WiFi router admin screens.

I hope this helps.


#3

I got curious and just had to try. Youtube works on my Raspbian for Robots.
There are two versions of Raspbian, Wheezy and Jessie. Jessie can handle Youtube, not Wheezy (or not out of the box). Maybe you have the previous version of Raspbian for Robots which was running on Wheezy?

That said, it is true that Raspbian for Robots is not as fully featured as NOOBS. That’s because it can still fit on a 4gig SD card. Things like Wolfram and OpenOffice were removed. The advantage of Raspbian for Robots is that you can skip the part of hooking it up to an HDMI screen and keyboard for original setup.

For jor14012 (original poster), if you prefer to get Raspbian for Robots, there are instructions here:
http://www.dexterindustries.com/howto/raspberry-pi-tutorials/install-raspbian-for-robots-image-on-an-sd-card/
that will let use use dex.local as per the tutorial.

Hope this helps!
Cleo