Can't open file camera-vision-logo.py


#1

I keep getting an error. I double checked the name of the .json file was correct so that doesn’t appear to be the issue.
I am in root@dex:/home/pi#


#2

error 2 and says no such file or directory


#3

tried again and got bash export 12345678fake.json not a valid identifier


#4

after moving the = sign


#5

I changed the = sign back and moved it all closer together so export GOOGLE_APPLICATION_CREDENTIALS=dave-12345678b.json and that seemed to fix it but now I am back to can’t open file camera-vision-logo.py


#6

Sorry I’m lost. You’re going to have to help me out.
Is there a specific project you’re attempting? I don’t recall that filename “camera-vision-logo.py

Cleo


#7

https://www.dexterindustries.com/howto/use-google-cloud-vision-on-the-raspberry-pi/


#8

This is the project. I think the problem stems from this line below: GET THE EXAMPLE CODE
sudo wget https://github.com/DexterInd/GoogleVisionTutorials - because this just downloads a link to that page.
I tried git clone https://github.com/DexterInd/GoogleVisionTutorials.git but that didnt work either. So I am downloading that repository to my windows docs folder and putting it on a USB and addng it to the home/pi that way and we will see if that works.


#9

That works! Seems to be a problem with the sudo wget - as it just gets the webpage where the repository is located. Newbie at Linux doesn’t help either.


#10

Good its working! Have fun with google cloud! it’s really awesome stuff!