Chainable LEDs[SOLVED]

Hi Karan,

Soory to disturb you again.
It has been a wile since I used github.
How do I update the local copy of the GrovePi repo on my Rasp?

I know this is basic material, but I can’t remember how to do it.

My GrovePi folder is in my root directoy.

Kind regards,


Hey Freddy,
The code is in another branch so this might be a bit more harder. I’ll try to help you out. It might be easier to download the latest version of the GrovePi from here: and then unzip it, or if you are running the Dexter Industries image, just run the DI_update on the Desktop and the repository should be updated.

Next go to the GrovePi folder on the Desktop and switch to the branch which has the changes by using: sudo git checkout firmware_1_2_6 and you should be able to follow the directions in the last post after this.

Do let me know if this helps.


Hi Karan,

I was able to download the zip file and to unzip it on the desktop.
However when I supply the command sudo git checkout firmware_1_2_6, the following error appears:
fatal: Not a git repository (or any of the parent directories): .git

Indeed in my original GrovePi folder there is .git folder, but not in this one.
I tried to copy the new firmware folder to the old one and then entered the sudo command, but it failed as well since it does not recognizes the firmware_1_2_6.

Thanks for your assintance.


Hey Freddy,
Did you enter into the GrovePi folder and then enter the command. Can you run git status in that folder and attach a screenshot of what you get.


Hi Karan,

Here is the screen dump.

Kind regards,


Not really sure why it is not working for you. Can you run this wget in a folder, this will download the experimental firmware and run avrdude -c gpio -p m328p -U flash:w:grove_pi_v1_2_6.cpp.hex next, which will install the firmware.

To update the software, run cd /home/pi/Desktop/GrovePi/, then git fetch origin, then git checkout firmware_1_2_6 and then cd Software/Python/grove_chainable_rgb_led/ and you should be in the examples repository. See the screenshot attached. Do this on the Raspbian for robots image.


Hi Karan,

I am back again.
I am still unable to install t a new version.
I see that now it is 1.2.7
When I perform a firmware upgrade, I can see the folder [git checkout firmware_1_2_7].
However when I perform the upgrade following the guidelines of the web site, it performs as indicated but when I check the firmware it indicates 1.2.2.
Please advice…



P.S. I will work on a new project this winter and need to purchase new hardware etc.
Do you recommend to upgrade the old raspberry to the new Raspbian Jessie so that I have both systems on the same level?

Hi @cluckers,

Can you try the Chain-able LED program with Firmware 1.2.2 and check if its working. If you don’t find it working then you can update the Firmware to 1.2.6 as 1.2.7 is still under testing. Our firmware update script updates the firmware to 1.2.2 only and so to have your firmware updated to 1.2.6 follow the instructions in this post.

I would recommend you to upgrade to our Raspbian for Robots Jessie image as our Software works best on this and we have customized the Raspbian image to make it more user friendly. You can install the Raspbian for Robots image following the tutorial here.

Please let us know if this helps,

Hi Shoban,

If you look at the history of this conversation, you will see that I had the problems with the chainable leds since October 2015. Yes I have tried it with the 1.2.2 and that is what I am currently using.
I will try the 1.2.7 firmware if I am able to perform the upgrade.

After that I will try to upgrade to the Raspbian for Robots.

Many thanks for your fast replay. I will keep you posted.

Kind regards,

Hi Shoban,

Me again.
I do not know what I am doing wrong but the command is not working. The system just put the word bash in front of it.

Kind regards,

Hi Shoban,

I was to early.
I am now on 1.2.6 and I will keep you posted.

Kind regards,


I tested the Leds with 1.2.2 and 1.2.6 and it is not working properly.
Sometimes the color change command is ignored.
Some year ago Karan promised me to test it in your environment so that I am sure that nothing is wrong with my hardware.
I also have ramdom port reading errors… I also mentioned this in another threath, but it seems that I am not the only one.
Concerning the uggrade to Raspbian for robots, I need an aditional memory card, because I do not want to take the risk of loosing everything.
Kind regards,

Hi Shoban,

I have ordered a new pi3 and a new GrovePi+ startup kit to make sure that I do not have any hardware issues.
Normally it arrives today. I will then use it with Jessie…

As indicated 1.2.6 is not functioning with chainable leds.
Has the 1.2.6 firmware been tested with the DHT temperature and humidity sensors?
I have 2 sensors, a blue one and a white one (I changed the sensor type in my simple python program to test).
None of them seems to work with the 1.2.6. Is this a known issue?

As this is now going on for a very long time and no solution is provided or even foreseen in the near future i would appreciate your honest answer to the following questions:

  1. Will there be sometime in the future a tested solution for this çhainable led
  2. Would it not be better for Dexter to remove this sensor from the GrovePi+ list?

For the last 2 days I am posting results from what I tried but it seems that nobody is reading my messages or bother to answer them.

I also posted another issue concerning unstable port reading.
Again, we know it is a reproducible problem, so I would like to know if there is a recommended python based workaround or solution for it. I posted in a previous threath how I handled t, but again it is not bullet proof.

Last but not least, I am from a small country Belgium, and it is very difficult to purchase a single GrovePi+ board here (startup kit is no problem). The prices they use are also very high comparing to the US especially your preferred dealer in France is ripping people off.
Have you any idea what the import taxes (in %) in Belgium would be if I purchase directly from Dexte?

Kind regards,


Sorry for taking this long to reply back. I had missed this post.

I just tested the chainable RGB led’s at my end and it seems to work. I think it has been working for some time and we also have a small project that uses it here.

Can you try out the following:

  • First make sure that you are using the latest version of Raspbian for Robots from here
  • Next update the GrovePi firmware from here . First make the script executable

sudo chmod +x

then run it :

sudo ./

  • After this, can you check the firmware version from here and make sure it is 1.2.2. (I still have to test it in 1.2.6 and 1.2.7)

  • Next try out the two examples here other than which is there only for historical purpose.

Can you let us know if it works any better. Also, can you start with 4 Chainable LED’s because that is what we have tested with.

There are a few more pointers that you should be careful about:

  • Make sure that the LED are connected in the right way with the input wire connected to the IN port and the wire going to the next port connected to the OUT port otherwise it might not work properly
  • Make sure that you have a beefy power supply. Each of these LED’s takes ~60mA peak so 10 of these could take ~600mA and the Pi could take 1-1.5 A peak. So if you don;t have a good enough power supply then it could make the whole system unstable. We have seen problems around that too. I would suggest using a 5V 3A power supply if you are using 10 of these LED’s.

Coming to the shipping and import duty, they are directly handled when the package enters your country, and most probably you’ll be charged the import duty depending on the import rules and regulation in Belgium.

Do let us know if this helps.

Hi Karan,

Thanks for your message.
So far I tested the following with my new raspberry 3 and grovepi+ 1.2.7

  • Chainable leds: I used a 4 chain of leds (not 10 yet) and it worked as expected. Congrats, I am a happy person with this esult.

  • Port reading: I did a first test and it was without errors. However the test was very brief but I will do a more deep test in the near fuure.

  • I have to do some more testing with my Pi 2 and the old grove board, but I suspect the GrovePi board to be defective. Meybe that was blocking me already from the beginning. I had problems from the early start and needed to make a lot of workarounds for the port reading problem.

I will keep you informed.

Kind regards,


Hey Freddy,
Glad to hear that the chainable LED’s are working for you. I think with 10 LED’s you have to be careful with the power supply.

Regarding the older GrovePi, technically there should be no difference in how the hardware is arranged. Most of the changes are only aesthetic. Can you try uploading a new firmware to the GrovePi and see if that helps.

Do let us know how it goes for you when you get a chance to test it in depth.

Hi Karan,

I now had time to do some in depth testing.
I use 4 chainable leds and still have some errors.
I have a program in Python that I run for several days.
When the ‘sleep’ time is 0.5 sec, the leds are frozen in a certain status after a while.
When this period is increased, it seems to work better.

Please advice.

I have another question.
Since the barometer BMP180 is discontinued, can I use the BMP280 instead.
Are there changes in the python script required to do so?

Kind regards, (2.2 KB)

Can you run this and tell us which firmware version are you running . When you say they were frozen, what did you have to do to get them working normally.

We have not tested the BMP280 and do not have examples for it yet. However, it looks like there are examples avialable for the sensor here and here. You can give it a shot. You can also try out the high accuracy pressure sensor here, though this one is a little costlier.

Hi Kara,

The firmware version I use is 1.2.7.
When the problem occurs, the only solution is to completely shut down the system, leave it without tension for a while, and restart everything again.

Kind regards,

Hi all

I have a similar problem however I am running 20 chainable RGB LEDs. firmware version 1.2.7. If I run a short script such as the test script multiple times ( like 3 times ) in a row, first the LEDs go crazy then they freeze in place. running anything further does change some of them but not the correct ones and not to the correct value. up until then everything works. To fix this I have to reboot as nothing seems to correct them again.

all the best