Cinch Setup Script Invalid, and How I fixed it

Ok so I ranch on my pi and it said it didn’t know what a doctype is. So apparently A html file was put in a file which brought me to a github page with the script. Yah, that needs to fixed. Lol.

Hi @graykevinb,

Can you tell us how you ran the Try using sudo bash Also what was the exact error message that you got.


It might be faster (and easier) to download the full image for cinch here and install on an SD Card rather than run the update script.

Sorry for the late reply. I forgot exactly what it said, but It gave an error about it not knowing what DOCTYPE! was. I looked at the file and it was HTML. Perhaps it got there by accident. I did find the correct script under in the di_update folder. Perhaps I accidentally saved the github page on the pi’s home folder. I also was an idiot and blew raspbian up because when I ran the correct script, I ran it in vnc, and I force quit the pi because I
Lost WiFi…

Anyways I decided to ditch raspbian for robots, for different reasons. Using stock raspbian now. Also great job! Getting my brickpi setup on it was so easy!

Hi @graykevinb,

Good to hear that you were able to setup BrickPi easily on stock Raspbian. As an heads up, Cinch disables your wifi access as it creates an access point of its own called the Dex. This allows you to connect to Pi access point called Dex from your laptop, mobile and control your robot.

You also will be able to access the novnc and other features of Raspbian for Robots, after pairing up with the Dex access point. The only hiccup here is you can’t access internet with cinch, if you would want to , then you will have to have your Pi connected to your router with an Ethernet cable.

It will be helpful for us to improve if you could let us know what difficulty you had with Raspbian for Robots.


1 Like