Code with Python - 403 forbidden

I’m trying to code with Python in DexterOS for GoPiGo3 but every time I try to create a new file (text/notebook/terminal or whatever option) I get a Invalid response: 403 forbidden. If I select through the launcher page it’ll show an additional Launcher Error: e is undefined after I hit OK. Browser console shows I don’t have USB key too but I definitely have it plugged in. Not sure what’s going on here, tried with a few browsers and machines. Is there really no other way to program this thing outside the browser? Like connecting to it through SSH etc…


Hi @slouiecs,

So you’re telling us you can’t create anything within JupyterLab - be it to open a terminal, create a notebook or create a blank file.

One issue could be caused by not having the right filesystem on the USB key. The USB key must be a FAT32 filesystem. So can you check that first?

Second of all, you can SSH to it, but you first need to drop into the boot partition of the SD card on your computer a blank file called ssh (with no extension) in there.
After you boot up the robot and connect to it through WiFi you can SSH to it by using the following credentials:

username: jupyter
password: jupyter

You can then look and see if you’ve got the permission to see access your USB key - most likely that’s caused by wrong selection of the filesystem on the USB key.

Thank you!

Hi, I have the same problem. I checked the USB file system type and it’s vfat (note, this is the USB I received from Dexter Industries).


Okay, I’ve got 2 questions:

  1. What version of DexterOS are you running?
  2. Have you tried rebooting the Pi? Be aware that the creation of new files is only allowed in the default directory of JupyterLab.

Thank you!

I have the same problem and I am using the usb drive from dexter.

The solution may be to use Chrome instead of Firefox