Connect to GopiGo

I have set up my wifi to my phone network (4G) and I am trying to connect to the gopigo with Raspberry Pi 3. I am not able to connect to the dex.local site from my laptop on same wifi network I keep getting the error DSN not found.
May someone helps me
Thank for the help.

1 Like

What OS did you put on your SDcard?
What color LEDs, and solid or flashing, do you see?
Try from a browser (safari, chrome, Firefox, opera…)

I used the Raspbian OS
I see the green Led in GopiGo

So the current Dexter Industries “Raspbian For Robots”?

If yes, that is what I use also. (Although I am not using a phone as the router, I use country US, I disable IPv6, and I use a Mac.)

Maybe all you need is to figure out what the IP of the GoPiGo3 is, by running:

arp -a

in a command window. Then put that IP into your browser.

Here are the steps I use to set up my WiFi for GoPiGo3 with Raspbian For Robots:

GoPiGo3 Setup

*** Download Raspian For Robots

*** Flash SD card with Etcher
  Select the Raspian For Robots zip file
  Select the 16GB SD Card

=== Mount the card to allow headless configuration
- Pull card out, then reinsert for next steps

=== Enable SSH
- create file called "ssh" (or ssh.txt) in the Boot partition

=== Setup WiFi Headless

- create the file wpa_supplicant.conf  
   (quote chars must be straight up/down, traditional, not slanted/matched Unicode chars

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


=== disable ipv6

Browse the disk (boot)
Rt Click on System Volume Information->Open Terminal Here
cd ..

cp /boot/cmdline.txt /boot/cmdline.txt.bak
nano cmdline.txt
add to end of line/file:
save, exit editor

- eject disk

==== Raspbian First Boot 
-insert micro SD card
-power on

- on Mac (or your laptop) command window:  arp -a            to find IP given to RPi

pw: robots1234