Connection problems


#1

So I ordered this as a Kickstarter, and this week-end was going to be the week-end my son and I were going to work on this together, unfortunately it has been one problem after another. We are using a mac and Raspbian for Robots 2015.11.09 shipped by you, unfortunately we could not connect using the ethernet cable, I have been on the forums now for several hours researching the problem… we confirmed that the Pi was booting correctly and that the ethernet port had connectivity lights blinking, we tried reseting Bonjour and removed the Wifi dongle nothing worked. Then I read about setting a static IP and I followed the video and made the appropriate changes saved the file, ejected it from my mac inserted it back into the GoPiGo and BAM! now it does not boot nor do the ethernet lights come on. I give up!!! I have blown the whole morning my son is upset and I am about to pull my hair out. We don’t have a lot of money so spending several hundred dollars on something like this was a big purchase, Where do I go now?


#2

Hi Presby72, sorry to hear about the challenges you’re having. There could be other things to check for, including if you’re running a firewall that’s blocking the ethernet, running a VPN, or have something special with your network.

My quick response, if you’re having trouble connecting we have new software named Cinch that let’s you tether over wifi. It’s not perfect but we have seen success for people that can’t get past the first setup step. If you want to try it, you can download the file here: https://sourceforge.net/projects/dexterindustriesraspbianflavor/files/Cinch/

And you can see instructions for installing and image here: http://www.dexterindustries.com/howto/raspberry-pi-tutorials/install-raspbian-for-robots-image-on-an-sd-card/

And you can see a few quick tips on connecting with Cinch here: http://www.dexterindustries.com/topic/new-operating-system-raspbian-for-robots-cinch/

John


#3

Thanks for the quick reply, and that sounds great, but… I don’t think you read my whole post. I am no longer booting properly after trying to setup my IP static, so I think I now have bigger issues than not connecting


#4

presby72

It sucks that you weekend project has not gone well. I really do understand I’ve been there too. I use the GoPiGo in my classroom. I also use the new cinch software John is talking about. If you update your sd card to use the cinch I think you will have A LOT more success. It is worth the effort.


#5

Actually, I read the whole thing multiple times.

I don’t think you read my whole post. I am no longer booting properly after trying to setup my IP static, so I think I now have bigger issues than not connecting

To save you the details, somewhere in assigning th IP address you did something wrong and destroyed your SD Card; if it’s not booting properly, and it booted properly originally, you corrupted your SD cards. If you open the first link, it instructs you how to re-image your SD Card and recover from this.


#6

OK, well I followed your instructions on assigning the IP address and ejected the disk so I am not sure how “I” messed it up but OK. I followed the instructions, downloaded 2016.05.09 and flashed per instructions using Etcher still does not boot, the SD card works fine in my MAC but not in my GoPiGo.


#7

I apologize for your SD Card being corrupted. I did not mean to assign blame, I was just trying to explain in more detail what most likely happened to the SD Card you have in your possession. I apologize for damaging your SD Card.

"still does not boot, " Can you tell me what the lights are doing: are there no lights on the ethernet ports? Does the ACT light blink?

If you’d like us to send a replacement SD Card, please send a request here: http://dexterindustries.com/contact


#8

There are no ACT lights and no ethernet lights, funny though the flash of the SD card went perfectly and there are issues reading the card in either my PC or MAC


#9

Hey presby72,
It does look like the SD card is corrupted. If you don’t want to wait for the SD card to arrive, yoy can follow the guide here to burn the SD card http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/ and try it out.

-Karan


#10

Karan, I think he did follow those instructions once and had trouble with loading the image to SD card using Etcher. Is that right presby72?


#11

I was able to flash the card with no issues using Etcher and it looks good on all of my PC’s and MACs but my GoPiGo still won’t boot.


#12

Hi presby72, there may have been a problem with the ethcher software, I’m terribly sorry. You say you have a PC, is it possible to try to use the directions we have for the PC to re-image the SD Card?


#13

SUre I can try it on the PC but the image was flashed successfully onto the SD card. Starting to wonder if it is the card reader on the Pi


#14

Hey presby72,
The LED on the Pi blinks in a specific pattern in case of problems with the SD card or the SD card holder. Here is a link to the LED troubleshooting page: http://elinux.org/R-Pi_Troubleshooting#Normal_LED_status. Can you have a look and see if you are getting any of these error codes.

-Karan


#15

I get a solid red light, no green act at all, no ethernet lights. From what I read in the article it say that is a power problem. i have tried it both pluged into and using battery.


#16

We have seen solid red in cases of SD card problem. Can you burn the image and try again. Have you placed a request for a replacement SD card or do you have spare one lying around. It might be better to try a new one with this too.

-Karan


#17

Presby72, if you think your Pi is damaged, should we send a replacement for that as well?


#18

Presby72, if you think your Pi is damaged, should we send a replacement for that as well?


#19

I got the replacement card and still just get the solid red light no act light. I think it is the Pi, can you please send a replacement


#20

Please contact customer support about it, if you think the Pi is broken.