Corrupt Image File

gopigo3
powersupply
sdcard
pending
battery

#1

The image on the SD card for the GoPiGo that we have is apparently corrupted, so I have been attempting to install Raspbian for Robots on the SD card, but it returns the same results. After powering the robot, a green light near the power button starts to blink, and then it changes to a flashing red light. I am unsure of what to do because I have followed the directions for installing the software, but it hasn’t worked at all. Should we just get a new SD card if this can’t be fixed?


#2

Hi @berkowiczae,


We have 2 questions regarding your situation:

  1. What image burner are you using? - we suggest you use etcher.io .

  2. Did you check the MD5 hash after you had downloaded the image?


The micro SD card is most likely to be okay.

Powering up the GoPiGo and seeing an LED turn red while initially being green tells me there’s not enough juice. I suspect you’re referring to the GoPiGo's power LED.

Are you using a power-bank supply or just a discharged battery? Can you try powering it up through an USB and with a separate battery at the same time? This is so you can be sure you’re giving it as much as it needs.


Thank you!


#3

I used etcher.io to burn the image, and I did not check the MD5 hash after downloading the image (I really don’t know how). We are using the power supply that uses the 8 AA batteries. I also tried using a USB to power it, but it the light just changed to blue. I’m really not sure what that means, and I don’t know why the batteries wouldn’t work.


#4

I also just tried switching the SD card into another robot, and the SD worked in the other one, so you were right about the SD card being alright. However, the power supply worked fine with the other robot and the USB power should give it enough juice, but that doesn’t turn on a green light at all. We’re all really confused here, and we’re starting to think it might be an issue with the board.


#5

Hi @berkowiczae,

We want to be clear before we proceed any further: are you using a GoPiGo3 or a GoPiGo?
Second, did the robot ever work or have you been seeing this since you’ve opened up the kit?

Next, could you show us a close-up photo of your GoPiGo3/GoPiGo board? We want to see how the Pi’s pins are plugged into the board.
And lastly, could you switch the board (the GoPiGo board) with the other one? We want to see if by switching it, the one that doesn’t work still doesn’t work.

And for seeing it boot-up, I suggest you connect it to an HDMI monitor/TV. This way, you’re sure if it works or not.

Thank you!


#6

We have the GoPiGo3, and it hasn’t worked since we opened the kit. I would switch the boards, but right now I have time constraints that won’t let me get to it today.