Could Not Resolve Hostname


#1

I’m trying to connect my Raspberry Pi to my macbook via a usb/ethernet adapter. I’ve installed the correct drivers but I still can’t get it to recognize the Raspberry Pi. It says “ssh: Could not resolve hostname raspberrypi.local: nodename nor servname provided, or not known”

I’ve read the other threads regarding this issue and they are too technical for me to understand. I’m not a computer person and am trying to build a GoPiGo with my 8 year old son because he loves robots.


#2

Hey wilson, if we backup for a second: if you’re trying to connect over ethernet, a few quick questions:
1). Are you using the Dexter Industries SD Card or image?
2). Do the LED’s on the ethernet cable light up?
3). Have you tried to “ping” the Raspberry Pi? If you open terminal on your mac, and type in ping raspberrypi.local what do you get back?


#3

John, thanks for getting back to me!

  1. Dexter Industries SD Card
  2. There are no lights on the ethernet cable or the adapter that I can see, but the GoPiGo itself has several lights on.
  3. It says “ping: cannot resolve raspberrypi.local: Unknown host”

#4

No problem at all.

Part 2 is what concerns me. If you don’t see the led’s around the ethernet cable on the Raspberry Pi or your computer, you should double check that the cable is all the way in. It sounds like the Raspberry Pi is powered up. Can you double check that the ethernet cable is fully pushed into the ethernet ports?


#5

It was plugged in all the way so I tried it on a different computer with a built in ethernet jack and it worked. it must be the adapter that wasn’t working. Everything is working as expected now :slight_smile: Thanks!


#6

Perfect, no worries!