Dex.local: Unknown host[SOLVED]


#1

Hello, I had my GoPiGo all connected to WiFi but then updated the software. After that I could ping dex.local but on my computer when I tried to reach dex.local I got a “dex.local’s server DNS address could not be found” message. I watched the “tips” video and it said to shut down the software with “sudo halt” so I did that (since I couldn’t access the VNC page. Now when I start it up I can’t ping dex.local via WiFi and it’s not seeing the Ethernet when I plug it in. Still not getting anything in my browser at http://dex.local.


#2

Hey sberry, which version of our image did you start with? IE, what was the original name of the image?

Also, have you tried using our Fing tutorial for finding the Pi? http://www.dexterindustries.com/howto/fing-tool/ The Pi might be connecting to the network, or your computer may not be finding it.

Also, I would suggest you power the GoPiGo with the microusb while you’re trying to set it up, just to make sure it’s not a low power problem.


#3
  1. Any time you do a “sudo poweroff”, “sudo shutdown”, or “sudo halt” on the Raspberry Pi, you’ll have to turn it off and back on (or unplug it and plug it back in) to get it to restart.

  2. Depending on how thorough the software upgrade was, it may have taken out your wifi configuration. You’ll need to connect via Ethernet (and test using the “ping” command), then browse to dex.local and VNC in, then reconfigure your wifi connection.

2.a) The “dex.local’s server DNS address” error message is odd, but it sounds like it’s trying to translate dex.local into whatever IP address it used to be at — which likely changed after the software upgrade. Depending on what operating system your laptop/desktop runs, you may need to flush the routing table either with the appropriate command or by rebooting your laptop/desktop as well.


#4

Ha, just rebooting my computer totally worked! Thank you!


#5

Thanks for the tip about Fing – I didn’t need it but am glad to know about it!