DexterOS v2.5.1

Has anyone come across this issue?
Create DexterOS v2.5.1 ok. Rename GoPiGo WAP to RobotCar25 and Restart GoPiGo3.
Car won’t bootup and more interesting is the fact that the SD card seems to get corrupted and is no longer available to the burning software.
I tried to re-format the card with both Mac & Windows computers but neither OS can ‘see’ the card.
TIA Brian - from Stage 4 Lockdown Melbourne Australia…

1 Like

Followed your steps without any problems.

What are you using to re-format your SD cards?

In the past, I have had success using “SD Card Formatter” to format cards I could not otherwise access.

Available for download here:



Thanks Kevin for the info.
I tried the SD Card Formatter program, however it cannot ‘see’ either of the the SD Cards that are corrupted.
DexterOS v2.5.0 works well.
I wonder if the v2.5.1 image got corrupted during the download, although ‘balenaEtcher’ created the OS okay & also validated it okay.


If you only saw this once, I’d guess your SD card just picket that time to fail. But the same failure twice - strange - as you said, perhaps your download is corrupted.

As I wrote before, I followed your steps and v2.5.1 worked fine for me. I don’t normally use balenaEtcher, but I did this time. I just booted off the card I created again, connected to “RobotCar25” and all seems to be working.


Good news!!!
I downloaded v2.5.1 again and all went well.
Thanks for your help.



Sorry for resurrecting an old thread, but just in case anyone is reading this and contemplating downloading the 2.5.1 version of DexterOS, there is now an update to GoPiGo O/S 3 - the latest and greatest “Dexter” O/S

Here’s the release announcement:

Unless you’re running a really old version of the GoPiGo, you should seriously consider upgrading to this version.