dLight addressing in EV3


#1

I want to use the dLight leds on my EV3 robot. but I can’t get address 3 to work.

Address 0 is a broadcast and works for all leds (including address 3), 1 works, 2 works, 4 works, 5 seems to be a broadcast as well? but 3 does not do anything.

If I switch an other slave to 3 he does not work either, but a broadcast works fine…

Some help please.
Dimi


#2

Hi Dimi,
There was a small bug in the EV3 code. We have just updated the Dexter Industries EV3 block. Please update the block and the sensor should work properly.

Thanks for the reporting the problem.

-Karan


#3

I can’t find the file on your site anymore.

I keep getting error:

l);a=d[b].initiatorType;c[a]?++c[a]:c[a]=1;a=d[b].requestStart-d[b].fetchStart;0

Dimi


#4

I found your updated EV3 block. The addressing works, but now I can’t set the dlights to red except the big one… Even a broadcast does not work… A new bug?


#5

dimitri, I’m sorry for taking so long to get back on this. I’ll take a look today.


#6

hallo,i have this them problem with the red dLight on the big one. no red on three satelite. where is a new block for NXT and EV3?
many thanks


#7

Legoopa, If the red LED isn’t working, it’s most likely defective hardware. We’ve seen this a few times with the dLight and I’m not sure if the QA/QC process failed and we put out a bad batch of them. I had one sent back to me and tried to find a workaround, and unfortunately the issue seems to be in the hardware, not the software.

If I understand correctly, you’re working with Generation Robots at the moment, is that correct?

As for the EV3 software, you can find it bundled here: http://www.dexterindustries.com/site/?features=ev3


#8

I just received the my lights and downloaded the new blocks for EV3. Same problem. Red is bright on the first big then very dim on the other 3 smaller ones. Its strange, can not address them individually, they all just stay on but then I can switch them off no problem. Flashing works too.

Also tried Lejos but keep getting I2C timeout when trying to connect but maybe there is a bug in dLights class for EV3 0.8.1 beta? I have not seen any sample code or unit test.
I just tried something like this :

Port p1 = LocalEV3.get().getPort(“S1”);
I2CPort myPort = p1.open(I2CPort.class);
DLights lights = new DLights(myPort);

HW problem or no … but its strange that G&B, blink and on/off is working. Usually failures are more digital


#9

Sorry for double posting, but I got mine from Amazon due to prime shipping, so if they got a bad batch its good to know if I just should return them or if they should send out a new set. If the batch is bad might be just a waste of time and shipping money.


#10

Hey Stoffe, best advice is to return for a refund. We haven’t found a hardware solution to this problem so there’s nothing to exchange yet.

Again, sorry about this!


#11

Thanks, no problem things like this happen.
Just curious if the Java part should be functioning when I get a new HW. Amazon is good about exchanging, just hope is not every unit in their batch.

Also just to confirm that someone has tried this using LejOS on EV3? I’m used to have to hack around but its one thing if things are proven or if I’m the first one because then one can expect errors. Strange thing is that Ev3 home edition software could at least do some while Lejos nothing…


#12

Hallo, i sent my Set return to Generation Robots and hope of a new Set. Many Thanks have a happy new year.—sorry for my english- i am a german.


#13

Hi,

I suppose that the problem I reported 6 months ago is the same problem?

I am still waiting for an answer on this reply of August 5, 2014:
“dimitri, I’m sorry for taking so long to get back on this. I’ll take a look today.”


#14

Dimitri,
I’m sorry to have left you hanging like that. It seems you might have had the same issue, with the red light not working.
Best,
John


#15

Hi,

I just received a set of delights this week from Amazon.com and from reading the posts above I guess I received one of the “bad” ones. The main led will glow red, but none of the satellite leds will. They are sending me a new set and while I was waiting I thought that I would check the forum.

I sounds like I should have just asked for a refund instead because it sounds like there is a good chance the replacement set will be defective too.

Do you know any place I could order a “good” set from or when a "good’ batch will be available?

Thanks,
Allen


#16

We ordered 4 and returned 2. All had the same problem and we ended up using blue lights for the project. I suspect that this is not a bad batch but a problem with EV3 or something.
All the posts on Internet and videos where the lights are working are NXT. I would want to see proof that the lights are EV3 compatible …


#17

I haven’t tried them with my EV3 yet, all of the problems that I’m having with the red lights not lighting on the satellite boards are with them connected to my NXT.

I can get them to all light up green and blue, but the only one that will light up red is the led on the main board. When I try to light the others up red, all I get is a very tiny little pin point glow.

When I saw the other posts about similar problems, I assumed I having the same one.

My replacement set from Amazon should be here in the next couple of days. Hopefully, it will work without any problems. If not, I guess I will be returning both sets for a refund.


#18

Well, I’m really disappointed. I received the new set of dlights from Amazon today and unfortunately, they had the same problem. I’m returning both sets for a refund.

I’m really not sure what to do at this point - I was really looking forward to getting the dlights. I don’t know if I should try ordering another set from someplace else, or wait a few months, or just forget about them altogether.

I was hoping that “John” at Dexter would send a reply.


#19

I think that they just re-send the same batch that other people return to Amazon and not removing them from the market.
Would be great to know where to get a good batch and all this shipping returns cant be good business.

I hope someone at dexter answers to this post too. So far (0/4) aint a good record. No orange blink :frowning:


#20

Hey folks! John here from Dexter Industries, founder and original co-designer of the dLight. I am ready to absorb all your anger and vitriol!

The dLights are not fully RGB. Some mistake was made in the design, we’re not sure what it is or how to correct it. It’s not a software problem; we see the same issue with the EV3 as the NXT. Furthermore, we see problems with the EV3 and some scenarios because of EV3’s limited amperage availability.

The red will not work. We have no plan to improve or repair the dLight; we are offering it while supplies last.

We weren’t sure what to do and were ready to take them off the market. A few customers contacting us about the product and wanted it anyways. We’ve left it up for sale, what remaining supplies there are. We’ve changed to description to not include red.

I hope that helps. If you bought the product through Amazon, and you need the red LED, return it because this product will not work for you. Exchanging it over and over won’t solve the problem. If you bought the dLight through our website and need the red light, go ahead and contact me through our website, and we’ll try to make it right.