dTIR sensor not turning out data in EV3/Labview


#1

I have exactly the same problem like @amritz.fa and @pwatts in post 2066. The post was recently closed by admin JohnC without obvious resolution. Hence the new topic. I bought the dTIR sensor for our EV3 school project, installed the Dextor sensor blocks in Labview from GitHub, ran the test program posted by JohnC but the data output is a constant “-273.16” regardless of temperature.

Is this a faulty sensor or what is going on. Thanks.


#2

Hi @michael3,

Thank you for your response.
I’m going to bring @JohnC and @Matt into this discussion, as they have had worked extensively with these products.

Thank you!


#3

Hello @michael3, I’m sorry to hear about the dTIR. We have a hard time sorting out those that are having an issue with the firmware, and those that are having an issue with the sensor. The labview EV3 I2C software can easily fault. A few questions for you:

  1. Do you have access to an NXT? The NXT has rock-solid connections to I2C.
  2. Do you have a logic analyzer? Curious because it might help to troubleshoot the issue.
  3. Can you try the shortest sensor line possible? Have you tried this with different cables?
  4. Do you have RobotC or another language available to test with? We haven’t kept up on our labview drivers and the issue could be there.
  5. If none of the above work, one last question: do you ever get a logical reading, or is it always -273.16? If you unplug the sensor and replug it back in, do you ever get a decent reading?

Thanks. Sorry about this, we have had a hard time supporting the EV3 and Labview and I am very sorry for the poor quality of the software. We will do all we can to help out.


#4

Hi @JohnC
I remeber this list of questionsf. You asked this someone else in a post from 2015. The response from other people on the forum and reading between the lines of your post above tells me that the sensor actually does not work with EV3. However, you clearly advertis the senosr to be compatible with EV3 (see screen shot). Can’t you get one of your developers to plug it in on your side and confirm if this is actually working? I mean really, people have been having this issue in posts from 2015 and the problem has never been resolved. Amazon asks me to rate my interaction with Dexter. What am I going to do? Please support.

Your questions:

  1. No
  2. No
  3. Yes, tried different cables, always -273.16
  4. No, please check if your EV3/Labview drivers are up to date or don’t advertise this as EV3 compatible.
  5. always -273.16, like all the other users in this forum with the same issue.

Please support, cc @RobertLucian


#5

NB: Most of these posts seem to relate to the same unresolved support issue in connection with EV3 comptibility of dTIR.


#6

Hi @michael3,

I’m really sorry for the created inconvenience.
We will be on this issue first thing in the morning.

Hope we can solve the issue as fast as we possibly can.

Thank you!


#7

Hello @michael3, it would seem that you’re correct: the dTIR is not working with Labview EV3. The dTIR sensor should work with BrickPi3, NXT, and EV3Dev (not EV3-G, which is what most EV3 users use).

I am really sorry about this; we think that the EV3-G blocks stopped working with a firmware update that happened between now and 2014. We will be happy to offer a full refund, and we’ll make it more clear on the Amazon page and our web page that the sensor does not work with Labview. I’m sorry about the issue, and we’ll reimburse or replace for you.


#8

Hi @RobertLucian, have you maneged to get anywhere with this? Regards


#9

Hey @michael3 we haven’t been able to make any progress on supporting this sensor in Labview EV3.

Just to be clear: there is nothing further to do on this. If you would like to use a different programming language, the sensor will work. If you would like a reimbursement, please let us know.