Enabling both wifi adapters in Cinch


#1

I have a GoPiGo, which came with a Raspbery Pi 3 and a wifi dongle. I’ve successfully burned a Cinch SD card and it works just as expected.

What I’d like to do is to enable the other Wifi adapter so that both the built in wifi and the dongle is activated. I’d like one adapter to work exactly like it does now, enabling me to connect directly to the device. I’d like the other dongle to connect to the internet through my router.

How do I enable the other device and get it to connect to a wireless router?


#2

Your best bet is not to use cinch. You would basically need to setup a WiFi hotspot on a WiFi dongle. If you Google t you,'ll find lots of tutorials. Most are outdated though and I haven’t been able to get it to work. If you do could you please let me know how?


#3

Hello @zukpr, we’re glad to hear that Cinch worked well for you!

As you point out, Cinch doesn’t have a wifi connection and can’t get on the internet. This is by design; we’ve designed it to make it as easy to setup as possible.

If you’d like to setup Cinch that connects to the internet, you have a great option: Raspbian for Robots. With Raspbian for Robots, you can connect it to your local Wifi network, and connect to it from another computer on your network. You can find download and install instructions for Raspbian for Robots here.


#4

Thanks for both replies. I definitely understand making it as easy as possible to setup. That’s why I went with Cinch for the kids (we are setting up 5 - one each for four kids and one for me). I’ll experiment with the other image and see if I can get the other adapter working for direct connections. I’ll repost here if I figure it out.

I am interested, though - with Cinch, I can’t even find the other adapter. How did you change the configuration to prevent the other adapter from being available at all (even as showing up in ifconfig as unconfigured).