Error 1006 vnc


#1

Im able to connect to my gopigo over wifi and click to open a terminal through the web browser, but when I try a vnc connection in the web browser I get error code 1006, cannot connect


#2

Hey nwrousell, can you tell me a little more about how you’re trying to connect? Are you using a mac or pc? What browser are you trying to connect through noVNC with? Any more information you can provide would help.

This seems like it might be an issue with the noVNC software. The post related (https://ask.openstack.org/en/question/520/vnc-console-in-dashboard-fails-to-connect-ot-server-code-1006/) and the issue was solved for this person by restarting the Pi.


#3

We tried a restart and that did not work. We tried from several different browsers on both windows and chrome OS with the same result. Where are the config files for VNC located on the pi? (sorry I am new to this)


#4

Hey nwrousell, no worries. Thanks for that info.

I’m not sure what would have caused this, but part of the image might be corrupted. The only time we’ve seen VNC freeze like this before is when the disk is when the Pi has run out of space on the SD card. Probably at this point there are two things to try (in this order):

1). Expand rootfs, which is basically to get more space on your disk (did you add anything to the disk?). If you run “sudo raspi-config” and select the first option that shows up (1 - Expand Filesystem). If you run this and reboot, it might solve the issue.

2). Burn a new image. You can see directions here: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

If you’re interested in the location of the configuration files are here: /usr/local/share/noVNC/utils


#5

Thank you! It worked when we burned a new image. I am now coding python for the GoPiGo. :slight_smile:


#6

Excellent, great to hear!