Ethernet Connections


#1

HI,

I successfully assembled the GOpiGO and when I tried to connect to DEX.LOCAL/ either in the site and in the command prompt Its doesn’t work and both lights are blinking. What I have to Do to Fix That to get connected ?

I appreciate the help with this


Ethernet initial connection issues
#2

Are you using the Raspbian for Robots software?
Are you using a Mac or a PC?


#3

Yes–I believe so–I am using the chip purchased from
Dexter. I am trying to connect to my Dell D630 laptop running Windows 7


#4

So the ethernet cable is plugged into both the Laptop and the Raspberry Pi. You say “both lights are blinking”; are the lights on the Ethernet port blinking? Or are you referring to lights on the Pi board?


#5

Ethernet cable plugged into both Laptop and Raspberry Pi–CHECK.
On Ethernet port, only the Green light is blinking–the Orange light is steadily on. The message is “Ping request could not find host dex.local” or “Ping request could not find host raspberrypi.local” depending on which “ping” command we use–“ping dex.logal” or “ping raspberrypi.local”.

Please provide instructions on how to proceed.


#6

is iTunes installed on your Windows machine? Or have you installed Bonjour if iTunes isn’t installed? (https://support.apple.com/kb/DL999?locale=en_US)


#7

Good catch CleoQC. If your ethernet ports are on, there’s an electrical connection, for some reason your computer isn’t finding the Pi on the network. You can do a few things now:

  • Check if you have Bonjour installed.
  • Remove the wifi dongle on the Pi
  • Turn off wifi on the Mac and the PC.
  • Use Fing to check the IP address: http://www.dexterindustries.com/howto/fing-tool/ This might help you find the IP number, without using the “dex.local” name.

#8

iTunes is NOT currently installed on my Windows machine. (I have tried 2 different laptops–same result.) Bonjour is currently installed (on each of the machines that I tried.)


#9

Did you try using fing from the link the John had mentioned above and did it get you an IP address for the the RaspberryPi on the network.


#10

I have read a number of these posts regarding the inability to connect or ping. Unfortunately connecting the GoPiGo 2 to a wireless network is not an option as we are going to use these in a classroom. I have tried the following:

*reimaged the SD card with the lastest version of the software
*updated the hardware
*attempted to enter an IP address into the command line file on the os
*Enternet ports are lighting up and working.
*Raspberry pi is plugged in to electricity and not on a battery.
*I have checked the network connection and packets on the ethernet cable are being sent, nothing coming back.

Could I please get some help on what to do next?


#11

Hello @jenawaye
If a wireless network is not an option for you, look at Cinch or DexterOS.
Neither will require a connection. The Raspberry Pi will send out its own independent wifi signal to which you will be able to log in.

Cleo


#12

Cleo – thanks for this.

We were able to find a work around to the problem.

In the past we were able to log in to the VNC and see the software on the pi. Did you guys do away with that?

Betsy


#13

@jenawaye,

Great to hear that you found a workaround!
And yes, we still support regular VNC to connect to your robot. It’s available whether you use Cinch or Raspbian for Robots.
Cleo