Ethernet lights[SOLVED]


#1

Assembled my robot. Followed all the procedures. After connecting the ethernet cable, the two LEDS on the Pi are not lighting up. No ping either. So what is the next step? Thanks


#2

Hey Jawa13,
Can you give us a little more background? What version of the image are you using, what computer are you using? When you power up the Pi, describe the two power lights on it: do they turn on? Solid the whole time? blink?

The biggest thing we’ve seen when we hear about this: the ethernet cables aren’t pushed all the way in.

John


#3
  1. the image date is 2015.11.09. I got the kit from your kickstarter campaign.
  2. Using PC 64-bit, Windows 7
  3. When I power up (GoPiGo board), a steady green light comes up and stays.
  4. on the Raspberry Pi board, two lights comes up (green and red) and stay steady.
  5. Followed the instructions and ad assembled the robot. The only part so far NOT working is the Ethernet. NO Lights. No response to ping. I did download the apple software and installed it.

#4

Hi jawa13,
Let’s try to get the Raspberry Pi working for you first. Can you disconnect it from the GoPiGo and power it using the microUSB cable. Also make sure that the ethernet is connected properly and also check if the microSD card has not come out accidentally from the Raspberry Pi. Can you also restart your computer once and try using putty again with dex.local as the host name to connect to the Raspberry Pi.

Do let us know if this helps.

-Karan


#5

jawa13, if Karan’s advice doesn’t work (adding the USB power to the Raspberry Pi, checking the mechanical connection on the ethernet cable), the image has been corrupted on the SD card (this can happen when the power is pulled on the Pi or the sd card is popped out while the pi is on). I suspect the image has been corrupted because the two indicator lights on the Raspberry Pi (not the GoPiGo) stay solid and never blink.

Again, I would try these suggestions (they’re quick and easy to test). If they don’t work, your next steps is to replace the SD card. If you’re an advanced user and want to get going in a hurry, you can download and install a new image using these directions (http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/).

If you don’t think this procedure is within your capabilities, we’ll replace the microSD card.


#6

Thanks. I will try installing the new image myself tomorrow and let you know if I encounter any issues. I also have spare SD cards.


#7

Ok, great. We’d like to hear how it goes!

We haven’t updated part of the directions for the latest image (the checksum is still out of date and we reference a software release from earlier this year) but I’ll get it cleaned up in the next 12 hours.


#8

Updated. The Hash and the image name are updated. Also, there’s a pretty easy to watch youtube video here: https://www.youtube.com/watch?v=1J8AAww6Ucw


#9

Hi,

I got new two sd cards today. They were sent promptly and I received by overnight delivery. I appreciate your quick response and support.

I used the first card and the problem remains the same. As you suggested I am powering the PI with the micro usb and then connect to Ethernet. The problem is that the green & red light both are on and steady. Ethernet light never come up. I googled and the problem I have is exactly the same as one described here.
https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=86796

I have not used the second card yet. I do not believe the new card is corrupt. I know the cables are fine and the computers are fine. I have an some additional boards in my office and I will check them out tomorrow. I will also follow the steps and recreate the image on the first card (that came with the PI originally) this weekend. I need to resolve this issue so I can go tot the next step.

I am puzzled, and if you have any input, let me know.

Thanks
MJ


#10

Did you test the SD cards? is it possible at all you have bad batch of SDs? I tried both SD cards and I get steady green As far as I understand this means SD card is corrupt. Green must blink for a few seconds at least when it is accessing the SD card. I am going to recreate the image and see if that works. If you want I can show this over skype. Thanks


#11
I got new two sd cards today. They were sent promptly and I received by overnight delivery. I appreciate your quick response and support.
That's great to hear. Taryn is incredible at customer service and works really hard to support our customers. Thanks Taryn!

I took a quick look at the link you sent. I also found this link to a more in-depth look at startup issues. It’s very thorough and might be worth a look as it covers a lot of facets of failure to start. https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=58151

One thing occurred to me last night thinking about this problem: could the SD card not be fully seated? I tried a few things suggested in the above article to try to recreate the problem your seeing. One way to get both LED’s to go solid is to not have an SD card inserted; would be the same output if the card wasn’t fully seated in the microsd card slot. Is it possible to post a picture of the microSD card in the Raspberry Pi?

This is a video Taryn made to try to explain how the microSD card should seat (we’ve had questions about this issue before): https://www.youtube.com/watch?v=xQdCoA5T8Tk

It could certainly be a corrupted batch of SD cards. I believe it’s unlikely the batch was corrupted because we’ve been using the same batch in workshops and with other customers, however, it’s definitely possible and we won’t rule it out until we have you up and running.

We all want to see you succeed in getting this problem resolved, and we’ll keep working on it with you. Thanks for hanging in there!


#12

Hello,
I went through all the material you have emailed including the video. Inserting the sd card properly is basic step. Steady lights with card fully inserted However, as per your advice I double and triple checked. Attached is a pdf file showing the photos of SD card before and after inserting. So far the PI behaves as if there is no SD card. We get steady green light. I do want to recreate the image but I am so tied up I am not sure when I can get to that. My concern is what if this happens in the classroom? Let me know if there is another way to test the SD card?


#13

Hi jawa13,
I am just posting the solution to the problem so that other people on the forums can use this as a reference in the future.

The problem turned out to be because of Bonjour was not working properly on the Windows 7 system which was being used to connect to the Pi. Even after the wifi credentials were loaded on the Pi, and it was checked that the wifi works, Bonjour still refused to connect via WiFi but worked on Ethernet. Windows was able to connect to the Pi when the IP address of the Pi on the wifi was explicitly used instead of dex.local (which was found using the WIFi setup icon on the Pi desktop).

We are still looking into the reason why windows was unable to connect to the Pi via Bonjour and will update everyone when we find out more about the bug.

-Karan


#14

All issues seem to have been solved now. Thank you for your prompt response.