Ethernet Port Not Working


#1

Hi,

We have just received our GoPiGo and immediately started putting it all together. Thus far we have gotten to the point where we connect to the ethernet port and cannot get activity lights on the port and are getting no connection.

I was originally connecting to a MacBook Air, following the instructions to activate the port on the laptop. No luck. I’ve rebooted the laptop several times, reseated the cable and power cycled the Dexter as well. To ensure there was not a problem with my ethernet adaptor on my laptop I also tried to connect to my iMac, where I did not need the adaptor.

When I am attempting this the Dexter is powered. The Pi board shows red/green illuminated lights at PP10/PP13 respectively. The Dexter board shows a green illuminated light close to the power switch.

We attempted to reset the firmware, though all instructions describe updates from after logged into the Dexter unit so were unable to.

Any thoughts?

Thanks!


#2

Hey bbp2, sorry for the frustration, but thanks for a great detailed post about what you’ve tried so far. The ethernet lights coming up could be a few things, but let me ask a few questions that we’re covered in the first post:

1). Just to confirm, you’re using Raspbian for Robots image. Is that right? What is the date on the image?
2). You’re powering this through a Raspberry Pi Power supply or other 2A power source (not a laptop); correct?
3). What version of the Raspberry Pi are you using?
4). You wrote that "The Pi board shows red/green illuminated lights at PP10/PP13 " Do you have an ACT and PWR Light? Does the ACT light blink or is it solid?

Also, I’m curious, you wrote “We attempted to reset the firmware, though all instructions describe updates from after logged into the Dexter unit so were unable to.” Can you describe this a little more, what you did, or the directions you followed?


#3

Thanks for the reply. Here are the answers to your questions:

  1. We are using the Raspian for Robots image. The date of the image is 2015.11.09.
  2. Correct. We have tried powering both through the 2A power source as well as the laptop. Same results.
  3. The model of the Rasberry Pi is B+ V1.2
  4. If you mean the ACT and PWR light on the ethernet port, no. There is nothing active on the ethernet port. I’ve tried connecting to multiple devices (iMac and MacBook Air) and different cables.

The only firmware instructions I was able to find assumed that you were at the device command prompt. Since we were never able to get that far we were unable to reset the firmware.

Thanks again!


#4

Hi there,
I’m a complete noob and had similar issues - couldn’t get the GoPiGo hooked up via the ethernet cable. Ethernet port is generally pretty dead. The green light at ppt 13 (if you look on the other side of the green board you will see that it labelled ACT) gave off a constant light. With some internet research I found that that constant green light means “No SD card during boot”. But…the SD card was in there. Could it be that…?
Yes, I took the SD card out, but it into my computer and found out that it was empty. Did I miss this in the instructions? If so, they are not quite …erm…dumb-customer proof. If not, maybe you guys at dexter want to check this. A knowledgeable friend of mine said it was actually rather unusally to have an image pre-installed, but then I would expect a hint, especially when there is a sticker on the card suggesting that there is some sort of raspbian actually on there.

Anyway, I followed the actually very good instructions on the dexter homepage, downloaded the most recent image and an image burner, burned the firmware onto the SD Card, inserted it into the raspberry pi and …it worked. First time for me doing that (hey, I said I was a noob) and so a good learning experience.

Thought I’d let you know, maybe it’s the same issue. And maybe John can clarify whether I was misreading the manual when I thought that there was already an image on the SD card. The label on the card states "Dexter Raspbian for Robots 2015.11.09"
Kind reagrds,
Jens


#5

Hi Jens,
Extremely sorry for the problems that you had to face. The SD card comes installed with the Raspbian for Robots image, however we have seen that a few of them end up shipping without the image loaded on them. We are trying very hard to make the improve the manufacturing process so that this does not happen in the future.

Whenever someone faces this problem, we usually give them the faster option of burning the image and if that is too much of a pain, then we offer the slower option of sending them a newer SD card by snail mail.

Again, I would like to apologize for the problem that you had to face. I hope that the GoPiGo is working well for you and do let us know if you face any other problems in the future.

-Karan


#6

Thanks Jens!

That was indeed our problem as well. Once you confirmed that I could load the image without logging on to the system I was then able to find the docs and get through that hurdle.

Thanks again,

Pete