Ethernet Port on RPi Seems disabled with Raspian for Robots Image

I am a new GoPiGo user so hopefully this is a simple oversight on my part. Backstory (not sure that it matters but here it is): I acquired a used GoPiGo kit from a friend. The original RPi (v1.2) seemed to have a hardware failure and could not boot from the SD card. I purchased a Raspberry Pi 3 B+ as an upgrade/replacement.
Problem: When I follow the setup instructions (Install the Image on The Raspberry Pi) I am not able to connect to the device. There are no ethernet lights on the Pi, when connected to HDMI no monitor connection is made, no ping response, no dex.local, no wi-fi connection, etc.
Question 1: Am I using the correct image
I have used tried the following images

Other notes: If I install the standard Raspberry Pi OS image on the SD card made available through the Raspberry Pi Imager tool, the ethernet port works fine and I can ping and SSH and see the desktop on my HDMI connected monitor. I can also see on my local Wi-Fi access point that the Raspberry Pi has connected to Wi-Fi. These gives me confidence that the RPi hardware is likely all in working order and that I am just not properly setting up the Raspian for Robots.

Question 2: Are there any additional settings to configure on the image before loading the SD card into the RPi, power requirements , connections. firmware, etc that need to take the place before or after the Raspian image is loaded so that it will work?
Power supply note: I have tried using the micro-USB power from the laptop direct to the RPi and separately an external power supply through the GoPiGo.

My son is anxious to get running but we are struggling to get past the start up, so we would greatly appreciate any guidance or experience with the ethernet port functionality.


For new users, the GoPiGo OS image is strongly recommended.


Allow me to add my endorsement to @cyclicalobsessive’s suggestion.

I would suggest making the same test with the current O/S and reporting results.

Also, you should run sudo raspi-config and make sure that both SPI and i2c are enabled, as they are hard requirements for the GoPiGo robot.


One last question:

Do all the other robot functions work?  (i.e can it drive around?  Do the sensors work?)

If not, there might be a bigger problem.

1 Like